Can't install Manjaro XFCE on new laptop - no network device drives

then you get the headers from a mirror, for example

You save the file on USB, then from that USB/folder where you save it, you run:

sudo pacman -U linux515-headers-5.15.28-1-x86_64.pkg.tar.zst
1 Like

The only USB sticks I have at home… physically do not fit near each other. Will try with SD card :slight_smile:

(here was a pic of my screen, but it looks I can’t add media to post yet :confused: )
No luck :confused:
It has to be USB stick? All shops are closed here in Bergen now…
4 warnings and an error - couldn’t find or read package

Seems to be a nice place there :wink:

When trying to install the rtw89-dkms-git from AUR? That can happen, yes, that is why i proposed to build it from source.

But another question: are you trying this on live media ?

If you have a bigger USB stick where now is the manjaro install, probably best to use Ventoy, drop the iso there and you can also copy the other files to it, hence is becoming also a storage.

So - my situation is:
I changed booting order to USB first on the Lenovo.
It started from my USB stick.
I choosen proprietary drivers (open source was the same for now)
It loaded. I see that I have no wifi and it has invalid drivers.

Now I am stuck with a new laptop with a USB stick in one of two USB A ports (Live Manjaro) and I can’t install it :confused:

I know what you mean, have no idea how to do it.
Now I have foudn a smaller USB stick and they both fit.
How the OS will recognise what USB to read from?
Because I have the same error on and on…

It is. Even when its rainging (aprox. 200 days a year) :smiley:

No worries about that in Live Media. Install the system, and once is installed and can have permanent changes, then you install the drivers for wifi, or did i miss something and the install does not work without internet connection?

Let me download the latest iso and try without internet …

Indeed. That is what I am against. I can’t install Manjaro without network connection.
It won’t let me through.

I did what I always do - dwl the latest ISO with all drivers and install it. Last time (macbook white 2008) I had issues with BT only. I just went to Arch depos and done. Drivers updated, bluetooth works.
Now… Installation is impossible without network connection…

Ok, so you see this once you started the installer

And you clicked Next and did all that and is not installing ? From my test is should work, and deal with the driver later. Also, from a fellow team member, plugging your iPhone into Manjaro box with enabled tethering on the phone makes it come up as a USB network interface.

1 Like

Jeez! I totally forgot!

Thanks!!! :smiley:
And I already miss Apple’s trackpad… this thing is atrocious!
So - now I am installing Manjaro. Will se what I can do with the network drivers

…but you did not check linux compatibility, so calm down. There are already topics about the problem you could have searched here in the forum.

I am calm. Just was in the mist. And I do not understand why I need network connection to install OS.
Anyway - I got help.
And I did not check if it is running Manjaro, because I already installed it on 3 other computers. Without a glitch.
All macs.
Only this bugger is a troublesome bastard.

Hello - my laptop is not flex and has Network card:
Intel Wi-Fi 6 AX200 (a/b/g/n = Wi-Fi 4/ac = Wi-Fi 5/ax = Wi-Fi 6), Bluetooth 5
What is interesting - my bluetooth is enabled, but sees no devices. I can see my Lenovo, but ca|t connect.
Neither wifi nor bluetooth.
Since this module is for both radios, I will assume both are not working.
I tried this:

  • dwl AX200 driver from intel(dot)com/content/www/us/en/support/articles/000005511/network-and-io/wireless.html,
  • extracted iwlwifi-cc-a0-46.ucode into /lib/firmware,
  • executed sudo modprobe -r iwlwifi and `sudo modprobe iwlwifi
  • no change

inxi -Fazy
will give more information about the system. Now that the system is installed will have more context.

lspci -n
is also good to identify the actual hardware …

1 Like

I have Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter. Thanks :slight_smile: One of the reasons I choose Manjaro (aside of light XFCE) is the community :slight_smile:
Now I need to figure it out how to install the driver

This would be the short version, but i think i mentioned it before.

1 Like

Now I am writing from my beloved Manjaro connected to wifi.
Thank you alll and especially @bogdancovaciu for help!
I started to use Manjaro XFCE aprox. 4 years ago, because I wanted an Arch distro.
Aside of great distro I met great community of users and power users who can and want to help noobies like me!
Thank you :smiley: Peace and love!!!

1 Like

Ah, i might misunderstood that you are still having troubles with it. Glad all was sorted out.
Kind regards!

I installed it just 10 min ago or so. Did not have time and patience to do this over Sunday. But now it is working!!! :smiley:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.