Can't install Manjaro with Newer kernels

The only iso I can install is Manjaro 19.0.2
Any iso after that is not installing in my system
iso with kernel 5.4 is installing bt iso with newer kernel is not installing (tried everything from Manjaro 20.0 to 20.1rc6)

Is there any solution?? !!!HELP!!!

I know that the guys that can help will ask you to paste the results for your inxi -Fxxxza -no-host in the thread.
The only thing I can think of is to check your bios version and see if there is an update for it.

I personally don’t have the necessary know-how to help you more than this.

1 Like

In the live environment I can’t even use the terminal…

I have an Intel mobo…last bios update was on 2018…I am on the latest bios version of that board
i7 3770
H61 mobo
GTX 1050 ti


The inxi report from that Live or Installed environment of that .ISO should be fine. Also, if you do install that, the updates might be a bit long-winded but will hopefully get you on the latest version without coming off the LTS kernel (just don’t replace with kernel-latest or whatever it is during the updates). If you do accidentally put in a newer one, just select the 5.4 in GRUB and set it to boot always off the last-used one (I can help with that if you need).

If I install 19.0.2 the update would b huge… that’s why I want the latest iso

I know it will be and might also be problematic, but at least if you boot from it & provide the inxi report, preferably in full-form like so (this will obfuscate (hide) any MAC addresses etc.) :

inxi --full --admin --verbosity=7 --filter --no-host

Also: How to provide good information

Hope this helps you to help us to help you, if you get what I mean :wink: :stuck_out_tongue:
All the best!

Host: manjaro-gnome Kernel: 5.4.23-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 9.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=0
misobasedir=manjaro misolabel=MANJARO_GNOMEM_1902 quiet
systemd.show_status=1 apparmor=1 security=apparmor
Desktop: Gnome 3.34.4 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux
Type: Desktop Mobo: Intel model: DH61HO v: AAG62445-102
serial: GEHO231000C2 UEFI: Intel v: HOH6110H.86A.0816.2018.1031.1524
date: 10/31/2018
Topology: Quad Core model: Intel Core i7-3770S bits: 64 type: MT MCP
arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 20
L1 cache: 256 KiB L2 cache: 8192 KiB L3 cache: 8192 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 49511
Speed: 1597 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1596 2: 1596
3: 1596 4: 1596 5: 1596 6: 1597 7: 1596 8: 1596
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ZOTAC driver: nvidia
v: 440.59 bus ID: 01:00.0 chip ID: 10de:1c82
Display: server: X. org 1.20.7 driver: nvidia compositor: gnome-shell
OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.59
direct render: Yes
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20
Device-2: NVIDIA GP107GL High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9
Sound Server: ALSA v: k5.4.23-1-MANJARO
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Intel driver: r8169 v: kernel port: d000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: down mac:
Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
driver: r8188eu bus ID: 1-1.1:3 chip ID: 0bda:8179 serial: 00E04C0001
IF: wlp0s26u1u1 state: down mac:
Device-3: TP-Link USB 10/100/1000 LAN type: USB driver: r8152
bus ID: 4-3:2 chip ID: 2357:0601 serial: 000001000000
IF: enp4s0u3 state: up speed: 100 Mbps duplex: full mac:
Local Storage: total: 1.93 TiB used: 104.62 GiB (5.3%)
ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
rotation: 7200 rpm serial: Z3TCQ0VZ rev: KC45 scheme: GPT
ID-2: /dev/sdb vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
serial: 2010E2910DFF rev: 023 scheme: GPT
ID-3: /dev/sdc type: USB vendor: Seagate model: BUP Slim BK
size: 931.51 GiB block size: physical: 4096 B logical: 512 B
serial: NA9E8CVM rev: 0304 scheme: MBR
ID-4: /dev/sdd type: USB model: TO Exter nal USB 3.0 size: 111.80 GiB
block size: physical: 4096 B logical: 512 B serial: 201503310007F
rev: 0204 scheme: GPT
ID-1: / raw size: N/A size: 11.70 GiB used: 781.7 MiB (6.5%) fs: overlay
source: ERR-102
System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 35 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 48%
Processes: 248 Uptime: 2m Memory: 15.60 GiB used: 1.20 GiB (7.7%)
Init: systemd v: 242 Compilers: gcc: N/A Shell: bash (sudo) v: 5.0.16
running in: gnome-terminal inxi: 3.0.37

Hmmm … NVidia graphics. Afraid I have practically no experience with those but does selecting C in GRUB for the commandline and adding nomodeset make any difference i.e. actually being able to boot into the Live system OK?

Tried that earlier
Same issue