Can't Install Manjaro with Live USB

Tried installing Manjaro using Live USB, alot of messages pops out and then blacks out (w/o cursor) when I install after the GRUB Menu. I made sure to verify ISO through SHA, redownload said ISO, and
I tried rewriting my USB and with Rufus and made sure to disable secure and fast boot, what should I do?
I’m coming from Windows 10 and would like to switch to Manjaro.

System Specs:
BIOS Mode: UEFI
CPU: AMD A6-7480 Radeon R5
GPU: Radeon R5 Graphics
RAM: 8 GB

Try with Ventoy:

Give us the link returned from below command

 inxi -MGCxxx | curl -F 'f:1=<-' ix.io

It didn’t work, in fact, I did not see the GRUB screen at all.

I’m new to installing Linux distros, can you specify how I can exactly do this?

Is AHCI enabled in BIOS/UEFI?

I’ve enabled it now, but I can’t install yet because my USB is being replaced right now, anything else I should do before my new USB arrives?

Hey mate,

I have also been a Windows user for life, but recently made the decision to switch to Linux & hence clean-swiped my SSD and installed Manjaro on it.

To make sure, nothing goes wrong, these are the steps I followed:

  • Downloaded the latest .iso files for gParted & Manjaro OS on my second laptop and used the latest version of Rufus to burn ISO files on two separate USB sticks.

NOTE: For gParted - Use a 4GB USB stick and for Manjaro, use at least 8 or more GB of USB stick.

  • While you’re creating the LIVE USB for Manjaro, Rufus would ask you the “mode”. Make sure you stick to the recommended one ( ISO image mode).

  • Once you’re sure about the settings, start the process & wait for it to finish.

  • Before starting with Manjaro installation on your system, back up your data on an external drive.

  • Run gParted through its Live USB and clean swipe your entire hard disk.

NOTE: DO NOT Create any New Partitions on your HDD right now.

  • Exit gParted and boot into Manjaro UI using its Live USB stick.

  • Once you’ve booted into the Live environment of Manjaro, connect to your Internet and double click the “Install Manjaro Linux” icon at the top-left corner of your screen.

  • Follow the installation steps and once completed, exit the environment and restart your system.
    Plug out your USB stick before restarting your system.

If everything went well, your system will land directly on the Manjaro welcome screen requesting for your " login password.

Let know if you still face any issues, and I would gladly help you out via remote setup.

Cheers,
Manu

You have to press and hold “ESC” to stop in the grub menu

1 Like

Problem, Rufus says that it can only write Manjaro in DD mode, is this fine? Also, I only have 2 4 GB USB Sticks, should 4 GB be enough to install Manjaro?

Opt for the one that comes with the (recommended) tag.
When I burnt the .iso file on the USB stick, Rufus recommended the ISO mode, so I kept it default.

If you’re getting DD mode as the recommended one, try with it once. You never know if that works for you.

Also, my suggestion is that you try with 4 GB USB. If that works, great, else, the only workaround solution would be to go for an 8 GB USB stick.

Let know how it works out for you.
If that works, great, else we shall try something else.

Cheers,
Manu

Back from being busy, but this actually worked.
If anyone else is having the same issues as me, Clean swiping through Window’s Reset PC (Enable Clean all data) also works, anyways, cheers!

Glad to read that it worked for you.
Enjoy working on Manjaro.

Note: Whenever you make a switch to another OS, clean swipe your hard disk using Gparted. It saves your time by ensuring that your hard disk doesn’t pop up any unwanted issues.

Cheers,
Manu

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.