Can't Install Manjaro - Partition Error

Hi I’m super new to Manjaro and recently new to Linux in general. I’ve tried to install Manjaro on my Asus laptop but I get this error creating partition:

Create a new partition (50.07 GiB, ext4) on ‘/dev/mmcblk0’

Job: Create new partition on device ‘/dev/mmcblk0’

Command: sfdisk --force --append /dev/mmcblk0

Command: sfdisk --list --output Device,UUID /dev/mmcblk0

Job: Set the label on partition ‘/dev/mmcblk0p2’ to “root”

Command: sfdisk --part-label /dev/mmcblk0 2 root

Job: Create file system ‘ext4’ on partition ‘/dev/mmcblk0p2’

Command: mkfs.ext4 -qF /dev/mmcblk0p2

Does anyone know what this means / can I use my laptop for linux / manjaro at all? Is there a way to fix this? Thank you so much for any help you can give me as I was excited to use Manjaro!

Hello @superficialfuture and welcome :wink:

By all good mean, there is no error. What makes you think that there is an error? The last command just creates a file system on your mmc.

Only thought here is that the mmc is broken and needs to be replaced.

there was here recently another user with the same issue as you, with asus and mmc disk, and with a solution:

Hey @brahma “way 1” worked modifying the sdhci in terminal and I was able to install Manjaro directly on the mmc disk! Thank you a bunch for your help!

Retract that last statement, haha. After running it off of the MMC drive it had a huge error mmc0: running CQE recovery and the wifi networking no longer worked. After restarting the computer, the wifi networking worked again and I haven’t gotten an error message back.

you need to add that quirk option to your kernel boot also, to make it permanent:
for that sdhci option, open this file:
sudo nano /etc/default/grub
and in this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
dont remove anything from there, just add it to existing parameters, save the file with: ctrl+x, update grub:
sudo update-grub