Can't install Manjaro KDE Full using the latest Live CD

I cannot install the latest version of Manjaro from the Live CD image. The problem is definitely not with the image. I created a bootable flash drive with Rufus on Windows - the problem remains. I burned Manjaro to DVD (with disk check) - the problem remains. I checked the image with SHA512.

What is the problem? The problem is that after the GRUB menu I see a boot console, then a boot screen (with three dots and a logo) and a black screen. That’s it! I can’t do anything, even go to console, I’ve tried different keyboard shortcuts (including Ctrl + Alt + F1-12). So I can’t even attach the logs.

I understand the problem is with the new kernel 6.1. My setup is Intel Core i7 6700K, AMD Radeon RX480, MSI MS-7977 (MSI Z170A Gaming M5). I don’t want to use old Manjaro images, maybe there is some way to solve this problem with newer images?

secure boot disabled in bios;
fast boot disabled in bios - you may not have this option;
fast startup disabled in windows, if you are dual booting;
AHCI enabled in bios, if you are on RAID, and you are dual booting, dont switch, otherwise you will not be able to boot into windows;
use Ventoy to flash the iso;
and if you think its because of the 6.1 kernel, you can download the latest manjaro iso with the kernel 5.15 from here:

1 Like

Using a DVD is very likely to take a looong time - perhaps even fail.

The read speed of a DVD will make it unbearable to install from such media.

Is it? And how did you reach that conclusion?

If you update after installation from an older image, it’s the exact same thing. You don’t need to reinstall Manjaro when a new version is released to be using that version. If you’ve kept the system up to date, you’re good. Hence, you can install from an older image, and just update the OS, and you’ll have the newest one.

I highly doubt it, but if true, and that’s a big if, why then would you want to use it, instead of an oldeer working one?

Thank you very much for your guesses, but I found what the problem was. The problem seemed to be with the mesa in the live cd.

The problem was solved very easily. I set the UEFI to Intel graphics priority and with the integrated graphics I was able to run the installation from the DVD (it wasn’t that slow as expected). The installation was successful, after it I switched the graphics to discrete and booted installed Manjaro without any errors.

I conclude that the problem was the mesa driver, which was built into the live cd. Perhaps it was not configured correctly?

P.S. Why DVD? I wanted to make sure that Rufus wouldn’t screw anything up, that I run a fully verified image without errors or modifications by third-party USB-writing software.

Very curious you failed to boot the install media but no problems with the installed system.

Seems there might be some issue with the configuration of the install medium.

So you changed the graphics priority in the system firmware to use Intel GPU.

After succesful install you changed the graphics priority to PEG (pci express gpu).

This is strange because the installed system is identical to the ISO system as the install process simply unpacks the the root and desktop images - then it applies the user configuration to the copied system.

The installer uses mhwd to determine which graphics driver to load for the live system so perhaps your graphic card is special in some way mhwd doesn’t know about.

It’s really weird, but that’s how it happened. I am surprised a lot. So you conclude that it’s mhwd issue?

I do not conlude anything as I don’t know and cannot set up a lab with the same card - I am speculating.

I don’t think it is a mhwd issue specifically - but mhwd uses a database over known graphics - and there is a very slim chance the card is not in the database - I grasp at straws here.

Perhaps you would be so kind to provide some hardware info using mhwd

mhwd -lh | curl -F 'f:1=<-'
mhwd -lh -d | curl -F 'f:1=<-'

Simply post the link you get from the commands

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.