Can't install Manjaro from flash drive. "error: unknown filesystem grub rescue>"

Hi, there!
I install Manjaro for the first time (and arch-linux-based too).
Now I have Windows 10 and Ubuntu installed.
I want to change Ubuntu to Manjaro.
I wrote Manjaro ISO to flash drive and set it to loading first in boot menu in BIOS.
But when system starts I get error
“error: unknown filesystem
grub rescue>”

Of course I tried to find solution first, but it was unsuccessful.
Output of command “ls”:
“(hd0), (hd1)”
But “ls (hd0)” or “ls (hd1)” outputs this:
“(hdX): unknown filesystem”.
And “ls (hdX)/” outputs this:
“error: unknown filesystem”.

Also, I tried to update grub using “sudo update-grub” command in Ubuntu.
Also I know that my “/boot/efi” locates in /dev/sda2 but not in /dev/sda1. Maybe there is the problem?
I want to add that I tried to reinstall Ubuntu after unsuccessful install Manjaro, and it installed successfully. Only Manjaro can’ tbe installed.
I’m hope for help.
Thanks in advance!

Hi :wave:

So you wrote the iso to an usb flash drive and booted the usb drive and got that error?

How did you write it to usb?

1 Like

Yes, using UltraISO in Windows. Also I do it to write Ubuntu ISO, and it works okay

Wait… UltraISO writes CDs/DVDs not flash drives… are you really sure you used a usb flash drive?

Yes. I’ve always used UltraISO for do it. “Bootable” tab then “Write disk image”. In opened window I can select(UltraISO selects automatically) the USB flash drive to write. And selects method USB-HDD+.

Just in case ultraiso have some weird behavior (i never used that tool)… please try to write the image with win32diskimager. It will write it as it is on the usb flash drive (raw). That should work on any system… never had problems with that tool.

1 Like

Wow, thanks, it’s really working. I don’t know how does it works with Ubuntu and Windows ISO files. But thank you very much. Solved!

1 Like