Can't install latest NVIDIA Driver

Hello everyone,

I would like to install the latest Nvidia driver (455), but unfortunately it does not work. I get the following errors:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Mon Nov  2 09:23:23 2020
installer version: 455.38

PATH: /home/merlin/.local/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin

nvidia-installer command line:
    ./nvidia-installer

Unable to load: nvidia-installer ncurses v6 user interface

Unable to load: nvidia-installer ncurses user interface

Using: nvidia-installer ncurses v6 user interface (widechar)
-> Detected 12 CPUs online; setting concurrency level to 12.
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '1326' of a runnning X server.
ERROR: You appear to be running an X server; please exit X before installing.  For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at www.nvidia.com.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

i currently have the 440 driver installed.

it seems difficult to upgrade the driver :frowning:

best regards
Merlin

You have to using MHWD tool instead BIN file!!
Paste results

mhwd -li
inxi -Fxza

Do NOT use the installer from Nvidia directly, use MHWD instead. There’s a reason why Nvidia drivers are packaged specifically for Manjaro, not even the packages are shared with Arch. If you insist and OK with breaking your system (maybe, one thing for sure, what you’re about to do is not supported), switch to a tty and kill your X server. Only then the Nvidia installer can run.

1 Like
mhwd -li                                                                                                                                                                                                     
> Installed PCI configs:
--------------------------------------------------------------------------------
                 NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-linux            2018.05.04                true            PCI
   video-nvidia-440xx            2020.10.04               false            PCI
inxi -Fxza                                                                                                                                                                                                   ─╯
System:    Kernel: 5.4.72-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=5f329a30-abde-41ad-aad2-31fbbf23f21a rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 iommu=pt amd_iommu=on kvm_amd.npt=1 video=efifb:off 
           Desktop: Cinnamon 4.6.7 tk: GTK 3.24.23 info: plank dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: 1.D1 date: 10/28/2019 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2 
           microcode: 800820D L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 97244 
           Speed: 3937 MHz min/max: N/A Core speeds (MHz): 1: 3937 2: 3898 3: 3933 4: 4025 5: 3881 6: 3861 7: 3832 8: 3995 
           9: 3574 10: 3978 11: 3783 12: 3836 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Micro-Star MSI driver: nvidia v: 440.100 
           alternate: nouveau,nvidia_drm bus ID: 25:00.0 chip ID: 10de:1c03 
           Device-2: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Tul 
           driver: vfio-pci v: 0.2 alternate: amdgpu bus ID: 26:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.9 driver: nvidia display ID: :0 screens: 1 
           Screen-1: 0 s-res: 5760x1080 s-dpi: 96 s-size: 1524x286mm (60.0x11.3") s-diag: 1551mm (61") 
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") diag: 584mm (23") 
           Monitor-2: HDMI-1 res: 1920x1080 hz: 120 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
           Monitor-3: DP-0 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") diag: 584mm (23") 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 25:00.1 
           chip ID: 10de:10f1 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Tul driver: vfio-pci v: 0.2 
           alternate: snd_hda_intel bus ID: 26:00.1 chip ID: 1002:aaf0 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 28:00.3 chip ID: 1022:1457 
           Sound Server: ALSA v: k5.4.72-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: e000 bus ID: 22:00.0 chip ID: 10ec:8168 
           IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.29 TiB used: 1.60 TiB (69.8%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G2X0C-00L350 size: 465.76 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 101110WD scheme: GPT 
           ID-2: /dev/sda vendor: SanDisk model: SSD PLUS 1000GB size: 931.52 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 00RL scheme: MBR 
           ID-3: /dev/sdb vendor: SanDisk model: SSD PLUS 1000GB size: 931.52 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 00RL scheme: MBR 
           ID-4: /dev/sdc type: USB vendor: Kingston model: DataTraveler 3.0 size: 14.44 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: PMAP scheme: MBR 
Partition: ID-1: / raw size: 465.46 GiB size: 457.16 GiB (98.22%) used: 341.84 GiB (74.8%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 49.1 C mobo: 41.0 C gpu: nvidia temp: 52 C 
           Fan Speeds (RPM): fan-1: 1197 fan-2: 2216 fan-3: 614 fan-4: 574 fan-5: 601 fan-6: 622 gpu: nvidia fan: 0% 
Info:      Processes: 385 Uptime: 54m Memory: 31.31 GiB used: 6.45 GiB (20.6%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: 1964 pacman: 1960 lib: 519 flatpak: 0 snap: 4 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.05 

Thank you! i was able to install the driver with MHWD! :slight_smile:

-> https://www.addictivetips.com/ubuntu-linux-tips/nvidia-graphics-drivers-manjaro/

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.