Can't install gdm-prime: depends on gdm

Hi! I am using Manjaro Gnome with gdm-prime setup as the display manager to properly handle my hybrid graphics card setup (Intel + Nvidia).

When trying to update gdm-prime from the AUR, pamac shows that it depends on the default gdm package, although they can’t be both installed at the same time.

I tried installing gdm and removing gdm-prime, but pamac still did not allow me to install it.
Now I would like to get gdm-prime back: I can’t just use vanilla gdm since I need Prime support.

When running pamac build gdm-prime I get:

Cloning gdm-prime build files...
Generating gdm-prime information...
Checking gdm-prime dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  gdm-prime  46.0-1                                 AUR
To remove (1):
  gdm        45.0.1-1  (Conflicts With: gdm-prime)  extra

Total removed size: 5,0 MB

Edit build files : [e] 
Apply transaction ? [e/y/N] y

==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: nick

Building gdm-prime...
==> Making package: gdm-prime 46.0-1 (tue 09 apr 2024 12:00:00)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating gdm git repo...
  -> Found 0001-Xsession-Don-t-start-ssh-agent-by-default.patch
  -> Found 0002-nvidia-prime.patch
==> Validating source files with b2sums...
    gdm ... NOT FOUND
    0001-Xsession-Don-t-start-ssh-agent-by-default.patch ... Passed
    0002-nvidia-prime.patch ... Passed
==> ERROR: One or more files did not pass the validity check!
Error: Failed to build gdm-prime

How to solve this conflict?

I do not see a conflict, it just fails to build for some reason.


…might have something to do with this:

So I suggest refreshing you mirrors.

sudo pacman-mirrors --fasttrack=5 && sudo pacman -Syu

And then try again:

pamac build gdm-prime

Hope this helps!

I’d imagine that gdm-prime 46 also requires GNOME 46? Which isn’t on Manjaro stable branch yet.

Theres something screwy with that AUR package.

You can see the comments at the page

And it was updated for 46, so that would be needed to be compatible.
If you are still on gnome 45 … you in fact would not want to update this to 46 even if you could.

Your problem right now is explicitly this

And finally,

Just in case there is a misunderstanding. gdm-prime is not required to use PRIME/prime-run with Gnome/Manjaro.
It would appear it is an attempt to have PRIME working for GDM. But I dont really see the point.
Its your system. I just wonder if there is any actual need for this package.
(especially if you arent going to be matching upstream at all, such as by using Unstable Branch)


Thanks, everyone!
So the best solution for me would be installing gdm-prime 45 with makepkg, considering the repository in this version.

@cscs about that:

It would appear it is an attempt to have PRIME working for GDM. But I dont really see the point.
Its your system. I just wonder if there is any actual need for this package.

I installed gdm-prime following the instructions given in the optimus-manager repository, and after that I finally got my graphics cards working properly. With that setup I’m able to decide if I want “hybrid, nvidia or integrated” GPU startup modes.

optimus-manager is discouraged for many reasons, including the extra hacky things it requires.
(like augmenting your display manager)
I would suggest envycontrol as a superior alternative for a ‘switching’ utility, if one is needed.

But again thats up to you.


Thank you, @cscs!
Indeed, switching to envycontrol and keeping the standard gdm worked for me.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.