Can't install drivers for veikk drawing tablet

New to linux, just switched from Windows 10, I’m currently trying to download drivers for my veikk drawing tablet

when running make or sudo all install clean to close out the instillation requirements i’m met with this.

make -C /lib/modules/5.13.15-1-MANJARO/build M=/home/josh/veikk-linux-driver modules
make[1]: *** /lib/modules/5.13.15-1-MANJARO/build: No such file or directory.  Stop.
make: *** [Makefile:8: all] Error 2

the fix for this is to turn off secure boot, well that’s already been done. so solution 2 is to run

 sudo apt install mokutil openssl

cat >>/tmp/x509.conf <<EOF
[ req ]
default_bits = 4096
distinguished_name = req_distinguished_name
prompt = no
string_mask = utf8only
x509_extensions = extensions

[ req_distinguished_name ]
O = Example, Inc.
CN = Example, Inc. Kernel signing key
emailAddress =

[ extensions ]

sudo openssl req -x509 -new -nodes -utf8 -sha256 -days 99999 -batch -config /tmp/x509.conf -outform DER -out pubkey.der -keyout priv.key
sudo mokutil --import pubkey.der

then running make sudo make install. But i run into an error with these last three steps

“EFI variables are not supported on this system”.

I’ve looked into the solutions for this, make sure all the boot settings are uefi and not legacy.


sudo modprobe efivarfs

chroot into the mounted root partition, which at this point i find out my partition isn’t mounted for whatever reason, find a fix which for some reason only temporarily mounts my partition.


chroot /mnt
mount -t efivarfs efivarfs /sys/firmware/efi/efivars

which then just gives me “mount point does not exist.”

I’ve spent two days on this with of which feels like there should be a simple solution. Please tell me there is.

Hello @IkuzoJosh and welcome :wink:

Are you sure that you booted Manjaro in EFI mode? Since the errors appear, I would say you installed and booted Manjaro in BIOS mode.

Can you check it?

test -d /sys/firmware/efi && echo efi || echo bios

I know, the name “BIOS” is commonly used for marketing and naming to not confuse consumers, but BIOS and UEFI are 2 different Systems.

apt or apt-get is the package-manager for debian based systems. On Manjaro it would be pamac or pacman and the package names can differ.

1 Like

ohhh, it seems i did install it in bios mode, shoot. How would I go about switching to EFI mode, is there a simple script I can run or do I need to do a clean install and run it on UEFI from there?

and I did end up using pacman for that line of code, I just copied the code from the site i got it from.

I think you are asking to solve an error, when your original problem is really different. There are some veikk drivers in AUR. Install them with:

pamac build input-veikk-dkms

I’m quite sure you don’t need UEFI to compile some drivers. There something odd there.

the drivers aren’t my issue unfortunately, i was able to install those before and my tablet works fine. What I need though is gui to implement some functions like pressure sensitivity, and only allowing my tablet to work on one monitor instead of all. Bringing up the gui is what i’ve been trying to ascertain through the github of the creator of that input-veikk-dkms

I’m not sure is it what you want/need but in AUR there is also input-veikk-config: “A graphical configuration tool to easily customize the module parameters for the input-veikk-dkms”

Then please create a new topic, because the current topic and category is totally off the topic. If someone searches for a solution, it will really difficult for him/her. Thanks for understanding.

1 Like

I do have that, but i’m not sure of a way to open it without going to the github and following their code. Might there be something i’m missing?

If you read the comments on the package’s AUR page, you’ll see the answer: Run the tool with

sudo veikk-linux-driver-gui
1 Like

:sob: you’re a life saver, I made it more complicated than it needed to be, can’t believe I missed that. Thank you!

Still new to this so let me know if i need to change my category to something more apt.

I’m trying to download yum so I can download the necessary dependencies for an rpm package i’m trying to install.

It seems when I installed rpm that yum didn’t come with it. I’m trying to install yum on its own by going through the add/remove program yet every time I try to install it I get hit with

-unable to satisfy dependency ‘python2-pycurl’ required by urlgrabber
-unable to satisfy dependency ‘urlgrabber’ required by yum
Is there something i’m missing to be able to install these dependencies correctly?

What do you need yum for? Most programs that have only rpm or deb packages are already in AUR.

That being said, the PKGBUILD for yum hasn’t been updated since 2017, and people have been having issues with it.

This wouldn’t work. The PGKBUILD for that is broken as well as python2-pycurl isn’t in repo or AUR, which is why python2-pycurl is highlighted red.

EDIT: I totally read the wrong one from your message:

After installing python-urlgrabber, you’ll still need to fix the PKGBUILD for yum though.

I have the package python-urlgrabber built, unfornately after this when i try to build yum it still requires the urlgrabber dependency

I need yum to install the dependencies for a driver called veikk for my tablet, this specific driver is not one I can find in aur so i need to install via rpm

You can edit the PKGBUILD yourself, replacing urlgrabber with python-urlgrabber.

When you run pamac build yum, it gives you an option to edit the PKGBUILD

No, you don’t. RPM’s cannot be installed on Manjaro with foriegn package managers.

I’ve already installed this driver, this specific aur is provided by another user who doesn’t work on it anymore because veikk itself provided official drivers on their site for linux, this is what i’m trying to install. If I can’t install rpm on manjaro would i be able to install deb instead?

Oh, I see. I didn’t realize the AUR packages were created by a third-party.

What exactly did you download to begin with you mentioned in your first post here?

No, DEB’s are Debian packages. This is not Debian.

However, RPM’s and DEB’s are just archives, they can be extracted and repackaged. Most packages in the AUR with a -bin extension do just that.

My first post here I was trying to download an aur made by jlam55555 which had some bugs that no one works on anymore, which I didn’t realize until today.
I found out that Veikk created official drivers on their site for linux

since I figured I wasn’t on debian, I thought downloading and installing the rpm would work but then I ran into the yum issue.