Can't install drivers for rtl8188eu

I tried to install the driver from add/remove software it failed.
then tried terminal with git
git clone GitHub - lwfinger/rtl8188eu: Repository for stand-alone RTL8188EU driver.
cd rtl8188eu
make all
{make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.8.1-3-MANJARO/build M=/home/adil/rtl8188eu modules
make[1]: Entering directory ‘/usr/lib/modules/5.8.1-3-MANJARO/build’
make[1]: *** No rule to make target ‘modules’. Stop.
make[1]: Leaving directory ‘/usr/lib/modules/5.8.1-3-MANJARO/build’
make: *** [Makefile:155: modules] Error 2}
make install
{install -p -m 644 8188eu.ko /lib/modules/5.8.1-3-MANJARO/kernel/drivers/net/wireless
install: cannot stat ‘8188eu.ko’: No such file or directory
make: *** [Makefile:161: install] Error 1}

now I am not sure what to do.

Hi!
You can try with the 8188eu-dkms from AUR

yay -S 8188eu-dkms

What errors did you get then?

DKMS: add completed.
Error! echo
Error while configuring
Your kernel headers for kernel 5.8.1-3-MANJARO cannot be found at
/usr/lib/modules/5.8.1-3-MANJARO/build or /usr/lib/modules/5.8.1-3-MANJARO/source.
You can use the --kernelsourcedir option to tell DKMS where it’s located.
Error: command failed to execute correctly
Running post-transaction hooks…
Arming ConditionNeedsUpdate…
Install DKMS modules
==> Unable to install module 8188eu/v4.3.0.8_13968 for kernel 4.19.139-1-MANJARO: Missing kernel modules tree.
==> Unable to install module 8188eu/v4.3.0.8_13968 for kernel 5.8.1-3-MANJARO: Missing kernel headers.
==> Unable to install module 8188eu/v4.3.0.8_13968 for kernel 5.7.15-1-MANJARO: Missing kernel headers.
Transaction successfully finished.

Blockquote

yay -S 8188eu-dkms

Blockquote

tnx for the advice but it failed too

You need to install the kernel headers, first:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')
1 Like

Hi!!
You need to install linux58-headers first then install the drivers

1 Like