Can't Install, Calamares freezes, "Waiting for 2 module(s), 32 second(s)"

Hi everyone, I’m new to manjaro (and linux in general) and i would like to install it, but I’m struggling on it.
I recently bougth a laptop in which i wanted to make a dual boot. I installed windows, made a partition for linux, booted manjaro on an USB and boot it. Once I’ve opened the installer, it starts loading and always freezes after 32 seconds. stating Waiting for 2 module(s), 32 second(s) I’ve tried with Manjaro Gnome and i3wm. furthermore i tried ubuntu and also froze.

I tried to install it on another device and I succed, so i guess that neither the ISO nor the pen drive is the problem.

I have an Acer Aspire 3 A315-23-R9BD


open the installer in debug mode and you will see where it hangs and which modules:

sudo calmares --debug

Please post the output here.

Thanks :wink:

Hi, again.
after the 32 seconds the entire system freezes, and i cant do anything, neither the mouse nor the keyboard respond, so it’s dificult (if I’m not missing anything, impossible) to post the output, due to the fact that i cant do anyting but to shut down the laptop.

Without log, i can’t say anything… beside this, Acer has a really bad support for Linux.

In general you should be able to switch to another TTY with CTRL + ALT + F3 ?

Maybe try the Architect Version?

hi, when 5 sec have passed, the log says:

 void Calamares::requirementsChecker::reportProgress()
    Remaining modules: 2

And repeats until it freezes.
before that, it is stated:

Calamares::RequirementsList GeneralRequirements::checkRequirements()
Need at least storage bytes: 8482560409
void Calamares::RequirementsChecker::addCheckedRequiements(Calamares::Module*)
Got 0 requirements from "users"
KeyboardPage::onListVariantCurrentItemChanged(QListWidgetItem*, QListWidgetItem*)::<lambda()>
xkbmap selection changed to: "us" - ""

I dont know if this is useful, but it’s all I can do.

1 Like

Seems to be a problem with your HDD/SSD…

Did you also try to start calamares as root? There is a problem with the permission handling on the KDE ISO… maybe other ISOs also effected?

Could you provide the output of:

sudo parted -l
efibootmgr -v

Did you check that fastboot is off in the UEFI?

Still :thinking: what this could be.


sudo parted -l

it starts thinking and then the system freezes, with no output.

The output of

efibootmgr -v


BootCurrent: 0002
    Timeout: 0 seconds
    BootOrder: 0000,0001,2001,2002,2003
    Boot0000* Windows Boot Manager	HD(1,GPT,1724ba0a-aa19-485d-bb08-63bca019fad4,0x800,0x200000)/File(\EFIa.c.c.1.-.f.3.2.b.3.4.4.d.}...a................
    Boot0001* UEFI_SHELL	HD(1,GPT,1724ba0a-aa19-485d-bb08-63bca019fad4,0x800,0x200000)/File(\EFI\UEFISHE
    Boot0002* USB HDD: TOSHIBA TransMemory	PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)/USB(1,0)/HD(1,MBR,0x0,0x
    Boot0003* Yes	PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)/USB(1,0)/HD(1,MBR,0x0,0x41f27c,0x2000)/File(\efi
    Boot2001* EFI USB Device	RC
    Boot2002* EFI DVD/CDROM	RC
    Boot2003* EFI Network	RC

Did you check that fastboot is off in the UEFI?

Yes, it is

Hey! I just bought an Acer Aspire 3 A315-23 yesterday and ran in to this very problem. The problem seems to be with the WD Black NVMe SSD. I can only speak for myself but my computer have the exact same specs as yours, except I only have 256gb of storage. However, I was able to boot my computer with the newest version of Manjaro (kernel 5.8.18-1) but it seemed like it wouldnt find my ssd.

However after I asked google I found the solution:

Edit startup parameters (by pressing ‘e’ at grub menu) to include nvme_core.default_ps_max_latency_us=5500 put this right after quiet
After install and when restarting again edit startup parameters in the same way.
Finally, when fresh install is booted: edit /etc/default/grub in the same way one last time. Finish it of by running sudo update-grub to make the parameter run without having to edit the parameters at every startup.