Can't install Brother MFC-6490CW

Hello everyone,

I’m a new Manjaro user and I can’t make my MFC-6490CW printer/scanner work in USB. the device appears when doing a lsusb.

I first tried setting it up with system-config-printer : the printer was detected and added, but I can’t print or scan.

I then tried to use Brother drivers and after download, followed Brother’s instructions. Nothing is detected, again can’t print or scan.

Any suggestions ?

Looked in the AUR?

I just got a second hand MFC-9970CDW witch give me trouble to get it working. Printing was too high on the page with the AUR driver (first lines were missing). The solution was the “generic” Brother driver I found in Endeavour forum (2nd post link)

https://support.brother.com/g/b/downloadend.aspx?c=th&lang=en&prod=mfcl2700dw_us_eu_as&os=128&dlid=dlf006893_000&flang=4&type3=625
Your printer is in the Compatibility model list
The script is straight forward and it is working for me at first shoot.

Thanks a lot for your answers,

@merlock : I tried, did the makepkg, it says :

error: failed to commit transaction (conflicting files)
brother-mfc6490cw-lpr: /usr/bin/brprintconf_mfc6490cw exists in filesystem
Errors occurred, no packages were upgraded.

seems like it was already installed by the Brother drivers, but doesn’t work…

@lopasilver : that’s the exact one I installed, it did not work.

Follow those same instructions to uninstall/remove whatever you installed, then try to install the AUR packages again.

Or, if the built package is still on your system:

sudo pacman -U <path_to_your_*.pkg.tar.zst_file> --overwrite /usr/bin/brprintconf_mfc6490cw

Thanks. I tried it, it executed properly, but it’s still not working.

I think I’m about to give up, I’m not using this printer so much and I’ll boot on windows the rare times I need it. I’m not surprised though, Brother printers are always atrociously bad with drivers, even on windows. For comparison, I just installed a Samsung M2026W laser printer without a hitch. 3mn, it works. Brother : 3 hours (at least), doesn’t work. But I learned how to install AUR packages.

Anyways, thanks for your quick support, that’s awesome !