Can't install any Manjaro variation

Hello! Thanks for taking the time to read this and respond if you choose so.

I have an older laptop (alienware m5700-r2) that I’m trying to put Manjaro XFCE or KDE onto. I tried using etcher and rufus for the iso and I made sure the iso was 32 bit and have used two different flashdrives. After using etcher/rufus there is only one folder inside the drive which is titled efi. Plugging it into the laptop and trying to boot from the drive just takes me to the prior windows 10 installation that already exists on the machine. The BIOS is pretty barebones too.

Since manjaro failed to boot into I just installed linux mint which works fine however I would much rather use manjaro. Any information would be greatly appreciated.

32 bit version have been abandoned some time ago, you only get 64 bit version by now.

You have the new 20.1 isos you can fetch from :

The laptop is only 32 bit. You can still get the legacy 32 bit isos off the download page.

The 32bit support has been unsupported for some time now and i think even the repositories are gone.
Link to the old message/thread about it by philm

Also please note the text on the download page:


The Release Archive are unsupported.

Do not use an archived ISO for installation.

Which version did you get by the way? I can only see 18.04 for Xfce 32, which is oooold.

Ah okay, didn’t notice that it said

Do not use an archived ISO for installation.

I used that one. I primarily want an arch based system as I like to be able to customize my system from the bottom up.

In the link @Takei provided, you have lists of distributions supporting still 32 bit.
Manjaro not anymore.

Then you might want to take a look at arch linux 32bit as that might fill your needs.

1 Like

Thank you both for responding. I think I know what to do from here and will check out bluestar.