Can't import pictures from camera with shotwell


I use Shotwell to import pictures from my camera and other USB devices such as my iPhone. I’m not sure what changed but suddenly I can’t access the pictures on my Canon camera or my iPhone anymore. When I connect the devices I get a popup message showing me the the connected cameras. But when I click on “Open in File Manager” Dolphin just shows my Home folder. When I try to import pictures in Shotwell (like I used to do without problems) it gets stuck on “Fetching photo information” and nothing happens.

I tried different cables and USB ports, which made no difference. I checked if the devices are recognized with lsusb. Here is the output:

lsusb | grep Canon
Bus 002 Device 007: ID 04a9:3272 Canon, Inc. EOS 700D
lsusb | grep Apple
Bus 003 Device 010: ID 05ac:12a8 Apple, Inc. iPhone 5/5C/5S/6/SE

When I insert the SD card in the card reader directly I can access the contents with Dolphin without any problem. Shotwell on the other hand still gets stuck on “Fetching photo information” when I try to import from the SD card.

I’m confused. Any help would be greatly appreciated!

Hello @jfb and welcome :wink:

Have a look here to get more information: Apps/Shotwell/Architecture/Logging - GNOME Wiki!

According to the website the log of shotwell is normally here: ~/.cache/shotwell/shotwell.log

You can run it on the terminal like that to increase the log information:


Do you get an output from mtp-detect (with the devices attached)?

Thank you for your suggestion. The Shotwell logs did not reveal anything helpful, unfortunately.

But I think I identified the problem and found a solution, although I’m still not sure why exactly this was happening. First, I reset Shotwell by deleting cache with rm -r .cache/shotwell and settings with rm -r .local/share/shotwell, which resolved the issue of Shotwell being stuck on “Fetching photo information” when accessing the camera or phone. When I connect a device now and open Shotwell everything works as expected.

If, on the other hand, some other application, e.g. Dolphin or Gwenview, accesses the camera or phone before Shotwell, it wont’t work. Shotwell then complains that “the camera is locked by another application”. So possibly that was the problem all along and I just didn’t get that error message before resetting Shotwell. :person_shrugging: But for now everything seems to work.

Thanks again for your help!

thank you for your answer.

mtp-detect outputs

Listing raw device(s)
    No raw devices found.

Should that be something else?

I was expecting it to list the camera and possibly the phone.

In xfce, I don’t know about KDE or gnome, in Settings-Removable Devices-Camera there is a checkbox for Import digital photographs when connected. Maybe there is something similar on your system?

Doesn’t look like it. Thanks for the suggestion, though!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.