Can't Hibernate Using Swap File on a Fresh Install

I have a fresh Manjaro install and decided for a swap file for the first time. I had been using partition for many years and wanted to try file. However, while partition always worked out of the box, file gives me problems. When I try to hibernate, it says “Call to Hibernate failed: Not enough swap space for hibernation.”

Output of free is

               total        used        free      shared  buff/cache   available
Mem:         7982416     4155336     1127204      389204     3398792     3827080
Swap:         524284           0      524284

Maybe that’s not enough space but since the swap file was created by the installer, I suppose that the correct size of the file was chosen. (if this is the problem: how can I enlarge the swap file).

I am a bit lost in how to proceed. I tried some suggestions provided to similar questions but without any luck.

swapfiles require a bit of extra steps for hibernation.

Thank you for your reply. I saw this wiki but I had high hopes that there is an out-of-the-box solution. So I just decided to not give file a chance and return to partition.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.