Can't get Numlock to stay on between reboots or suspend at login screen


I have been through the Arch Wiki page Activating numlock on bootup - ArchWiki and tried every solution on that page that is applicable to my system*. I tried one method at a time and rebooted each time I finished.

So far the only change is that if I login with numlock off, it will turn numlock on afterwards. I’d rather have it turn on at the login screen as this is what I’ve been used to on all my computers over the years.

I’ve ran out of things to try now so any help would be greatly appreciated. :confused:

*Methods tried: Early bootup (mkinitcpio), With systemd service, Extending getty@.service, startx, and of course XFCE.

  • First, check your BIOS for an option to enable it.
  • Make sure numlockx is installed
  • Then check if your greeter has an option to enable numlock at boot.

There should be no reason for it not to work if you have done all of the above.

1 Like
  • No option available in BIOS
  • numlockx installed by default, double checked and it is installed and working in a terminal (on, off and toggle all work as expected)
  • Had to look up what a greeter was… I have LightDM GTK+ Greeter and there are no options in the GUI for setting numlock.

As a side note, on Windows 10 (dual boot on same machine) numlock is active at startup and the state persists between suspend/wake.

EDIT: Found the solution here: LightDM - ArchWiki

I didn’t even know what a greeter was (just assumed it was XFCE that was responsible for the login screen). Thanks to your post I was able to search what I needed and found a solution, thank you.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.