Can't get my wifi to work on manjaro xfce

Hi there, I am new on manjaro and in linux as well, after looking for a couple hours yesterday and today as well I still can’t get my wifi to work or get recognised (it was fine on windows).

I’ll post whatever I found that would seem to be useful
After writing the command in the terminal :
lspci -vvnn

I get this :
Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
Subsystem: Lenovo Device [17aa:c024]
Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 255
IOMMU group: 8
Region 0: I/O ports at 2000 [disabled] [size=256]
Region 2: Memory at d0900000 (64-bit, non-prefetchable) [disabled] [size=64K]

Any guidance is welcome, thanks for reading!

You need to install from AUR the driver rtl8821ce-dkms.
First, open pamac-manager and enable AUR support in preferences. Then noted the kernel you’re using with
uname -r
What you need is the series of the kernel, let say you have 5.8.10. Then you need to install the kernel-headers for that kernel, if you have more than one, the install them all with
sudo pacman -S linux58-headers
If you have kernel 5.4 it would be
Once you have it/them installed, you can install the driver with
yay -S rtl8821ce-dkms

This is what I get when trying to run the last command the rest did ran
bash: yay : command not found
------- EDIT ------
Ok I had to write this

sudo pacman -S yay

still I had this message

==> ERREUR : Cannot find the fakeroot binary.
erreur lors de la construction : rtl8821ce-dkms

ok this worked, to pass the fakeroot error

sudo pacman -S base-devel

Everything seem to have been installed but doesn’t seem like the wifi issue is fixed still

I am not sure what worked since I did whatever was written on some website : first link when you type ‘kimiyuki yukawa rtl8821ce’ on google and I did a reboot after that and it did work.
Thanks though!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.