Cant get manjaro to boot after messing with GPU drivers

Hello all!

When I turn on my notebook the login screen is only visible on the laptop display but not on the external screen I use via HDMI. After logging in external screen is working properly.

Now I’ve messed around installing and using Optimus manager which I regret now. After the command sudo systemctl disable optimus-manager I quit the application and uninstalled it.

The other problem is if I close my laptop lid the whole desktop session becomes unusably slow and sluggish. I get a notification from KWin that some effects has been disabled and after restarting it with Shift + Alt + F12 the desktop becomes slow as I described. Oddly when I open the lid and the laptop screen turns on, everthing turns back to normal and I can use the machine normaly.

Any help on either problems would be much appreciated!

EDIT.: Restarting KWin doesn’t seem to matter at all, laptop lid open everthing runs smoothly, closed it is a diseaster.


So after I found out that this is most likely to do with the GPU drivers I tried pressing the auto install drivers (both open source and proprietary). This threw me an error saying a conflict with optimus driver (as it wanted to install something called bumblebee) so after looking up how to remove a driver (hwid - -pci driver-name) and removed them, i went ahead with the auto install which worked. Then I rebooted and now the system doesn’t seem to boot, i just get a blank screen with the msi logo after grub exists.

How could I fix this?

Then I rebooted and now the system doesn’t seem to boot, i just get a blank screen with the msi logo after grub exists.

Hi @66Gramms! I think this guide could be a good starting point for you, basically when you see the black screen you want a tty terminal by using Ctrl+Alt+F3.

To avoid seeing only a black screen, in Grub, remove the “quiet” option (hit “e” on the grub entry you want to use for loading Manjaro, then look for and remove “quiet” and boot with ctrl+x)

1 Like

After removing the quiet option, i see the booting sequence stopping at “Starting bluetooth service…” And ctrl+alt+f2 or f3 doesnt work as i guess booting is not even finished :confused:

You’ll have to boot from a USB drive and chroot into the system. Then check which drivers are installed with mhwd -li. You can also see which drivers are available to be installed with mhwd -l.

Remove the installed drivers with mhwd -r pci <config> (see mhwd --help for more info).

Auto-install the desired drivers with mhwd -a pci nonfree 0300 (or, if you want a specific driver, mhwd -i pci <config>).

Exit chroot and reboot.

This will hopefully get your system up. After booting update your system.

This is a known problem when the NVIDIA GPU is used as an output sink. That’s very possibly what you experience.