Can't get librewolf to install after update, keep on getting target not found: librewolf

Can’t find a fix when I search, not sure if it’s my mirror list but I tried updating this and still getting target not found: librewolf.

  Kernel: 6.3.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.3-x86_64
    root=UUID=946d67f7-e2d1-44f8-96b2-4bf678b3bde9 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm:
    1: GDM v: 44.1 note: stopped 2: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: H110M-S2H v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: H110M-S2H-CF v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F22 date: 06/12/2017
  Info: model: Intel Core i7-7700 bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF2
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1150 high: 3600 min/max: 800/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 3600 4: 800
    5: 800 6: 800 7: 800 8: 800 bogomips: 57616
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ZOTAC driver: nvidia
    v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
    s-diag: 692mm (27.26")
  Monitor-1: DP-2 res: 2560x1440 dpi: 109 size: 598x336mm (23.54x13.23")
    diag: 686mm (27.01") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce GTX
    1070/PCIe/SSE2 direct-render: Yes
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:a170 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: ZOTAC
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
  API: ALSA v: k6.3.12-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.73 status: active with: 1: pipewire-pulse
    status: active 2: pipewire-media-session status: active 3: pipewire-alsa
    type: plugin 4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IF-ID-2: virbr1 state: down mac: <filter>
  IF-ID-3: virbr2 state: down mac: <filter>
  Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1:2
    chip-ID: 0b05:17cb class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 931.51 GiB used: 816.42 GiB (87.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DX002-2DV162
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC41 scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
    used: 816.42 GiB (89.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 231 Uptime: 1h 47m wakeups: 0 Memory: total: 16 GiB
  available: 15.58 GiB used: 3.28 GiB (21.1%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: 2061 pm: pacman pkgs: 2046 libs: 496 tools: pamac,yay pm: flatpak
  pkgs: 0 pm: snap pkgs: 15 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: yakuake inxi: 3.3.28

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

This might help

That’s an AUR package, not a Manjaro package. :arrow_down:

pamac build librewolf

… or…

pamac build librewolf-bin

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as descrribed above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

1 Like

I tried:

pamac build librewolf


pamac build librewolf-bin

but still not working, getting:

Transaction cancelled.

it’s working now, thanks for your help everyone

It worked fine here:

$ pamac build librewolf-bin
Checking librewolf-bin dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
librewolf-bin  115.0.1-1    AUR

Edit build files : [e]
Apply transaction ? [e/y/N] y

Cloning librewolf-bin build files...
Generating librewolf-bin information...
The PGP key 662E3CDD6FE329002D0CA5BB40339DD82B12EF16 is needed to verify librewolf-bin source files.
Trust LibreWolf Maintainers <> and import the PGP key ? [y/N] y
gpg: key 40339DD82B12EF16: public key "LibreWolf Maintainers <>" imported
gpg: Total number processed: 1
gpg:               imported: 1

==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: Mirdarthos (mirdarthos)

Building librewolf-bin...
==> Making package: librewolf-bin 115.0.1-1 (Tue 11 Jul 2023 14:56:11)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning source git repo...
Cloning into bare repository '/var/tmp/pamac-build-mirdarthos/librewolf-bin/source'...
remote: Enumerating objects: 2963, done.
remote: Counting objects: 100% (250/250), done.
remote: Compressing objects: 100% (141/141), done.
remote: Total 2963 (delta 127), reused 169 (delta 88), pack-reused 2713
Receiving objects: 100% (2963/2963), 3.45 MiB | 2.89 MiB/s, done.
Resolving deltas: 100% (1747/1747), done.
-> Found default192x192.png
-> Found librewolf.desktop
-> Downloading librewolf-115.0.1-1-linux-x86_64-package.tar.bz2...
% Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Dload  Upload   Total   Spent    Left  Speed
100 85.0M  100 85.0M    0     0  13.1M      0  0:00:06  0:00:06 --:--:-- 17.3M
-> Downloading librewolf-115.0.1-1-linux-x86_64-package.tar.bz2.sig...
% Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Dload  Upload   Total   Spent    Left  Speed
100   566  100   566    0     0   1189      0 --:--:-- --:--:-- --:--:--  1191
==> Validating source files with sha256sums...
source ... Skipped
default192x192.png ... Passed
librewolf.desktop ... Passed
==> Validating source_x86_64 files with sha256sums...
librewolf-115.0.1-1-linux-x86_64-package.tar.bz2 ... Passed
librewolf-115.0.1-1-linux-x86_64-package.tar.bz2.sig ... Skipped
==> Verifying source file signatures with gpg...
librewolf-115.0.1-1-linux-x86_64-package.tar.bz2 ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
-> Creating working copy of source git repo...
Cloning into 'source'...
Switched to a new branch 'makepkg'
-> Extracting librewolf-115.0.1-1-linux-x86_64-package.tar.bz2 with bsdtar
==> Entering fakeroot environment...
==> Starting package()...
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/lib/librewolf/browser/defaults'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/lib/librewolf/browser/defaults/preferences'
'/dev/stdin' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/lib/librewolf/browser/defaults/preferences/vendor.js'
'/dev/stdin' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/lib/librewolf/distribution/distribution.ini'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/16x16'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/16x16/apps'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/src/source/themes/browser/branding/librewolf/default16.png' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/16x16/apps/librewolf.png'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/32x32'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/32x32/apps'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/src/source/themes/browser/branding/librewolf/default32.png' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/32x32/apps/librewolf.png'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/48x48'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/48x48/apps'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/src/source/themes/browser/branding/librewolf/default48.png' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/48x48/apps/librewolf.png'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/64x64'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/64x64/apps'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/src/source/themes/browser/branding/librewolf/default64.png' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/64x64/apps/librewolf.png'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/128x128'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/128x128/apps'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/src/source/themes/browser/branding/librewolf/default128.png' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/128x128/apps/librewolf.png'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/192x192'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/192x192/apps'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/src/default192x192.png' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/192x192/apps/librewolf.png'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/symbolic'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/symbolic/apps'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/src/source/themes/browser/branding/librewolf/default16.png' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/icons/hicolor/symbolic/apps/librewolf-symbolic.png'
install: creating directory '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/applications'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/src/librewolf.desktop' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/share/applications/librewolf.desktop'
'/dev/stdin' -> '/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/bin/librewolf'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/lib/librewolf/librewolf-bin' -> '../../bin/librewolf'
'/var/tmp/pamac-build-mirdarthos/librewolf-bin/pkg/librewolf-bin/usr/lib/librewolf/' -> '../'
==> Tidying install...
-> Removing empty directories...
-> Removing libtool files...
-> Purging unwanted files...
-> Removing static library files...
-> Stripping unneeded symbols from binaries and libraries...
-> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "librewolf-bin"...
-> Generating .PKGINFO file...
-> Generating .BUILDINFO file...
-> Adding install file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: librewolf-bin 115.0.1-1 (Tue 11 Jul 2023 14:56:33)
==> Cleaning up...

Checking keyring...                                                                                                                                                                                                                                     [1/1]
Checking integrity...                                                                                                                                                                                                                                   [1/1]
Loading packages files...                                                                                                                                                                                                                               [1/1]
Checking file conflicts...                                                                                                                                                                                                                              [1/1]
Checking available disk space...                                                                                                                                                                                                                        [1/1]
Installing librewolf-bin (115.0.1-1)...                                                                                                                                                                                                                 [1/1]
>>    Remember to check for changes in /usr/lib/librewolf/librewolf.cfg.pacnew
>>    as those will not automatically overwrite your existing librewolf.cfg.
>>    We would encourage you to migrate your own changes to the new overrides file
>>    at ~/.librewolf/librewolf.overrides.cfg instead, so making changes directly
>>    in your librewolf.cfg is not necessary anymore (in most cases at least).
>>    Check out
>>    for more information on this.
Running post-transaction hooks...
Arming ConditionNeedsUpdate...                                                                                                                                                                                                                          [1/6]
Refreshing PackageKit...                                                                                                                                                                                                                                [2/6]
Updating icon theme caches...                                                                                                                                                                                                                           [3/6]
pacman-backup.hook                                                                                                                                                                                                                                      [4/6]
Checking for .pacnew and .pacsave files...                                                                                                                                                                                                              [5/6]
Updating the desktop file MIME type cache...                                                                                                                                                                                                            [6/6]
Transaction successfully finished.

But, I haven’t yet done the update, so it might have to do with the current pamac issues. Could you try installing it manually? Or, if you have another AUR helper, try that.

I’m getting the same issue with any app from the AUR that needs updating using the pamac build command.

I’m assuming the issue is linked to the problem with the pamac GUI.

Yes but think the actual culprit is “libpamac” which was updated yesterday·

It’s OK. I’ve sorted this now. pamac build command will upgrade from the AUR via the terminal, and pacman -Suy does the upgrades from the official repositories .

The problem seems to lie just with the pamac GUI, so I guess I’ll have to wait until it’s fixed before using that again.

Not necessarily. You can use yay instead. :wink: :arrow_down:

yay -Syu librewolf

… or… :arrow_down:

yay -Syu librewolf-bin

Note: Like pamac, yay must not be used with sudo. It will prompt you for a password when necessary. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.