Can't get into Manjaro live session

Hello.
I’m quite a newbie in the Linux environment and three months ago i decided to install Manjaro
to try it out. Everything worked fine with some initial complications, but i managed to learn a lot of things and now i use this distribution as my primary OS. But then this problem appeared.
I was trying to make another partition in order to install another distribution. I prepared a USB stick as a bootable device and downloaded an ISO of Manjaro xfce. When i was in the live session, i used gparted to shrink my home partition to half its size; the process took some time but all things gone fine. I applied the changes and rebooted the system.
So here comes the problem: when i rebooted the system, the menu showed me two options, boot with open source drivers and boot with proprietary drivers. I selected both in two different occasions and in both a black screen appeared, not booting the system or taking me to the live session. Then i tried to use the other options of the menu but these only make the system boot normally to the already installed Manjaro distro.
I decided to try with other distribution. I prepared a device for Mint, and i got the same result. I did the same for Fedora, and got the same. Tried again with Manjaro, and again, nothing.
My guess is that something is messed with GRUB but i don’t know exactly what it could be. I used pacman to upgrade grub and its configuration multiple times and the problem didn’t go. Furthermore, i think that maybe my USB stick has some problems and i should try with another USB stick and do the same operations.
Briefly, i can’t access manjaro live session with a booteable device, in a machine that has only manjaro installed.
Inxi -Fazy throws this

System:
  Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=5ea4e06d-7c02-4e49-9215-e605e7db049d rw quiet apparmor=1 
  security=apparmor resume=UUID=ec385688-3999-4a2f-b637-3075171040ec 
  udev.log_priority=3 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: TOSHIBA product: Satellite C55-C v: PSCPAU-006NC1 
  serial: <filter> 
  Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 
  v: Type2 - Board Version serial: <filter> UEFI: INSYDE v: 1.10 
  date: 04/15/2015 
Battery:
  ID-1: BAT1 charge: 18.9 Wh condition: 18.9/44.1 Wh (43%) volts: 16.0/14.8 
  model: Panasonic PA5185U-1BRS type: Li-ion serial: N/A status: Full 
  cycles: 515 
CPU:
  Info: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 45 (69) stepping: 1 microcode: 26 
  L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 13573 
  Speed: 1597 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1597 2: 1597 
  3: 1598 4: 1596 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Toshiba driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0a16 
  Display: x11 server: X.Org 1.20.10 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 20.3.1 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Toshiba driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c 
  Device-2: Intel 8 Series HD Audio vendor: Toshiba driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
Network:
  Device-1: Broadcom BCM43142 802.11b/g/n vendor: XAVi driver: wl v: kernel 
  port: 5040 bus ID: 07:00.0 chip ID: 14e4:4365 
  IF: wlp7s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Toshiba 
  driver: r8169 v: kernel port: 3000 bus ID: 08:00.0 chip ID: 10ec:8136 
  IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 70.48 GiB (15.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABF050 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: 3M 
Partition:
  ID-1: / raw size: 228.59 GiB size: 224 GiB (97.99%) used: 70.48 GiB (31.5%) 
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.28 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 182 Uptime: 46m wakeups: 1 Memory: 3.76 GiB 
  used: 2.17 GiB (57.7%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.0 Packages: 1307 pacman: 1303 lib: 422 flatpak: 0 snap: 4 
  Shell: Bash v: 5.1.0 running in: xfce4-terminal inxi: 3.2.01 

This is the GRUB configuration file:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden
#GRUB_HIDDEN_TIMEOUT=10
#GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=ec385688-3999-4a2f-b637-3075171040ec udev.log_priority=3"
# GRUB_CMDLINE_LINUX_DEFAULT=" ipv6.disable=1 "
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

I thought recently that the problem could be a result of the disk shrinking operation that i did in the first step, but i’m not sure.
Thanks to whichever person reads this topic and throws me a light in this obscure situation.

Hi. Have you another USB key you could test? Which program do you use to flash the iso?

No idea about the why, but you could try the method below. No USB key needed to boot from an iso.

Yes, i do have another usb stick and i should test it soon. The program that i am using is rufus on a windows machine.
Thanks a lot for the related solution, i will try it immediately!

Well, it worked.
I did the steps on the guide and i managed to run a live session with a Manjaro xfce iso, making a custom configuration file for grub. When i rebooted the menu allowed me to run the downloaded iso without an usb!

It appears that the problem could have been the usb stick, maybe is damaged somehow.

Thanks a lot @Falav, this helped so much. I wonder now if one can do the same process with the .iso files from other distros.

1 Like

Wonderful! Yes, it should work too, but with slight different settings for the custom.cfg file.

But for Manjaro isos, it’s tested and approved.

1 Like