Can't get Freesync To work with my Nvidia-Card (G-Sync Compatible)

Hello Guys, I really hope you can Help me.
I have a Freesync-Monitor (MSI Optix MAG321CQR) and I can activate Freesync on Windows just fine, but on Linux the option to allow unsupported monitors is missing. In the Nvidia-Settings the monitor information also says “G-SYNC Mode Available: None” instead of Not Supported.

I’m suspecting these Kernel-Log Messages to be the reason, but I don’t know how I can fix the issue or override the deactivated option:
kernel: nvidia-modeset: WARNING: GPU:0: Microstep MSI MAG321CQR (DP-4): G-SYNC Compatible: EDID min refresh rate invalid, disabling G-SYNC Compatible.

I’m also getting the following missing files (don’t think that matters though?)
appimagelauncherd[5983]: Could not parse file “/home/acul/.local/share/applications/nvidia-settings.desktop”: Invalid key name: Path[$e]

I already compared the EDID-Files of Linux and Windows. They are exactly the same. I also tried overriding with an EDID-File on boot, but it either didn’t help or I did something wrong and it didn’t even override.

Adding the following under Device in the xorg-conf didn’t help either:
Option “metamodes” “DP-4: nvidia-auto-select +0+0 {AllowGSYNCCompatible=On}”

I’ve had this Issue for as long as I have used Manjaro and wanted to finally fix it, but I don’t know where to look or what to try anymore.

Please Help?

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  1. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  2. The output to xrandr and the technical specifications for your monitor would be helpful as well. (resolution and refresh rate list)

:+1:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

First of all thank you for your help! I’m trying to fix most Problems by my own using Wikis, but sometimes it’s just to much for me.

I also added the output of edid-decode.

inxi:

xandr:

edid-decode:

I’ve also updated my profile information, but here is my current setup:

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.1
Kernel Version: 5.9.1-1-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4770K CPU 4.40GHz
Memory: 15.6 GiB of RAM
Graphics Processor: GeForce RTX 2080 Ti/PCIe/SSE2
driver: video-nvidia-455xx

Monitor: MSI Optix MAG321CQR
Resolution: 2560 x 1440
Connected with: DP 1.2
Frequency:  55.3 to 162KHz(H)
Frequency:  48 to 144Hz(V) 

Modes:
640x480 60Hz
640x480 72Hz
640x480 75Hz
720x400 70Hz
800x600 56Hz
800x600 60Hz
800x600 72Hz
800x600 75Hz
1024x768 60Hz
1024x768 70Hz
1024x768 75Hz
1440x900 60Hz
1280x1024 60Hz
1280x1024 75Hz
1680x1050 60Hz
1680x1050 144Hz
1920x1080 60Hz
1920x1080 144Hz
2560x1440 60Hz
2560x1440 144Hz

A 162KHz monitor can not run 1440p/144Hz, that would require ~207KHz horizontally.

1 Like

You’re right. I didn’t notice that. It’s probably just a mistake in their Specs though.
The 162 also don’t appear in the EDID, but it does mention 222?

I honestly don’t understand most of this Timing Data. I guess I should read about the Display port spec a bit more.

I still don’t get why I can enable it in Windows then. Shouldn’t the driver force it off there too?

It seems MSI created a bit of a mess with that product, maybe you should contact their support? However, the horizontal frequency is specified as 162KHz everywhere by MSI itself, note that the vertical frequency is specified as up to 144Hz, as opposed to the precisely defined 162KHz horizontal.

If you are able to run 1440p/144Hz on Windows the max horizontal frequency is way higher than specified.
It is possible though that you are in fact running 1440i, interlaced modes need less bandwidth iirc.

Edit:
nvidia 455 is not yet compatible with kernel 5.9, you should try a different kernel, like 5.4.
I run a nvidia card and my gsync option works just fine on 5.4

1 Like

Edited that for you… :wink:

Do you need more detailed help with @440Hz 's comments? Because he/she’s saying the same thing I would have said, except I’d have added some commands to do what he/she said…

1 Like

I tried switching to a 5.4 Kernel, but I’m still getting the same error and no G-Sync modes.
It didn’t occur to me that the driver might not be compatible since I didn’t really have any problems, so thanks for the tip.

MSI is pretty unhelpful. I was stupid enough to mention the word Linux… I didn’t even ask any technical Questions about the OS, just if my Monitor could in theory have a corrupt EDID and I asked for the correct one to compare mine.

They told me they don’t support Linux.
I asked if they could get me the correct EDID File and asked about the horizontal refresh rate error.
They are ignoring me right now. I definitely won’t make that mistake again.

I’ll try to contact them with another email and also check Windows again. I’m starting to regret having bought this Monitor.

Thanks for all the help! I’ll keep you updated if I make any progress.

1 Like