Can't get extra monitor interface to show up

xrand shows ep1 (laptop screen), and dp1 and dp2 as disconnected. It also shows hdmi1 and hdmi2 separately and disconnected.

My laptop uses a USB-C Thunderbolt connection to provide the external hdmi interface. The laptop is capable of driving 2 external monitors plus laptop screen.

I have 2 USB-C devices plugged in, both have an HDMI. One by Aerofara also has VGA, ethernet and 3 USB3.0, plus analog audio and an SD card slot. The other dongle by Asus that came with machine has a USB-C, USB3 and HDMI.

Next thing I can think of to try is reboot into BIOS and see if there are any setting there that might cause these external HDMI ports to not show up under the OS.

Here are the system details from inxi:

System:    Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=db854aac-7229-47ea-a7f7-3759e8d8ecf5 rw quiet 
           root=/dev/mapper/luks-090603d0-d1e0-4d7b-8f76-beca97122ab2 apparmor=1 security=apparmor 
           resume=/dev/mapper/luks-a14c2250-047f-4a75-b878-dadced3ad126 udev.log_priority=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: UX490UAR v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: UX490UAR v: 1.0 serial: <filter> UEFI: American Megatrends v: UX490UAR.307 date: 04/17/2019 
Battery:   ID-1: BAT0 charge: 37.4 Wh condition: 37.8/46.2 Wh (82%) volts: 7.7/7.7 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: N/A status: Not charging cycles: 30 
Memory:    RAM: total: 15.50 GiB used: 2.15 GiB (13.9%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: A (10) microcode: D6 L2 cache: 8192 KiB bogomips: 32012 
           Speed: 700 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 700 2: 700 3: 701 4: 700 5: 700 6: 700 7: 700 8: 700 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
           clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c 
           flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt 
           invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe 
           pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap 
           smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
           vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo bus ID: 1-5:3 chip ID: 13d3:5755 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2") s-diag: 581mm (22.9") 
           Monitor-1: eDP1 res: 1920x1080 dpi: 157 size: 310x170mm (12.2x6.7") diag: 354mm (13.9") 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.7 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel alternate: snd_soc_skl 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0 chip ID: 8086:24fd 
           IF: wlp1s0 state: down mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 4-1.3.4:4 chip ID: 0bda:8153 
           serial: <filter> 
           IF: enp56s0u1u3u4 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> scope: link 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IP v4: <filter> scope: global broadcast: <filter> 
           IP v6: <filter> virtual: stable-privacy scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 349.68 GiB (73.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW512HMJP-00000 size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: CXY7501Q scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 459.59 GiB size: 451.37 GiB (98.21%) used: 349.68 GiB (77.5%) fs: ext4 dev: /dev/dm-0 label: N/A 
           uuid: db854aac-7229-47ea-a7f7-3759e8d8ecf5 
           ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%) used: 424 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
           label: N/A uuid: 0D20-FD74 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 17.05 GiB used: 1.8 MiB (0.0%) priority: -2 dev: /dev/dm-1 label: N/A 
           uuid: 589c0035-943f-4204-97cb-7c92a61e008f 
Unmounted: ID-1: /dev/nvme0n1p2 size: 459.59 GiB fs: crypto_luks label: N/A uuid: 090603d0-d1e0-4d7b-8f76-beca97122ab2 
           ID-2: /dev/nvme0n1p3 size: 17.05 GiB fs: crypto_luks label: N/A uuid: a14c2250-047f-4a75-b878-dadced3ad126 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 1-2:34 info: VIA Labs USB2.0 Hub ports: 5 rev: 2.1 speed: 480 Mb/s chip ID: 2109:2817 
           Device-1: 1-2.2:36 info: VIA Labs USB2.0 Hub type: Billboard driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s 
           chip ID: 2109:0100 serial: <filter> 
           Hub: 1-2.3:35 info: VIA Labs USB2.0 Hub ports: 5 rev: 2.1 speed: 480 Mb/s chip ID: 2109:2817 
           Hub: 1-3:39 info: VIA Labs Hub ports: 4 rev: 2.1 speed: 480 Mb/s chip ID: 2109:2210 
           Device-1: 1-3.2:40 info: VIA Labs USB2.0 Hub type: Billboard driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s 
           chip ID: 2109:0101 serial: <filter> 
           Device-2: 1-5:3 info: IMC Networks USB2.0 VGA UVC WebCam type: Video driver: uvcvideo interfaces: 2 rev: 2.0 
           speed: 480 Mb/s chip ID: 13d3:5755 serial: <filter> 
           Device-3: 1-8:4 info: Intel Bluetooth wireless interface type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 
           speed: 12 Mb/s chip ID: 8087:0a2b 
           Device-4: 1-9:5 info: Elan Micro ELAN:Fingerprint type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 
           speed: 12 Mb/s chip ID: 04f3:0903 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 4-1:2 info: VIA Labs USB3.0 Hub ports: 4 rev: 3.1 speed: 5 Gb/s chip ID: 2109:0817 
           Hub: 4-1.3:3 info: VIA Labs ports: 4 rev: 3.1 speed: 5 Gb/s chip ID: 2109:0817 
           Device-1: 4-1.3.4:4 info: Realtek RTL8153 Gigabit Ethernet Adapter type: Network driver: r8152 interfaces: 1 
           rev: 3.0 speed: 5 Gb/s chip ID: 0bda:8153 serial: <filter> 
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3500 
Info:      Processes: 244 Uptime: 1d 2h 24m Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1300 lib: 352 
           flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

I have been looking at this
Not sure if bolt or rather tbt would be good for you, but since you are on KDE Plasma, have you tried plasma-thunderbolt package ? Is also in out repository and it seems is using bolt, so you could start from there and report back.

I installed the both package (plasma-thunderbolt) and now I see a listing in the settings for Thunderbolt, but it says “Thunderbolt subsystem is not available”.

My BIOS disagrees. I have a function key for multi-monitor configuration which shows mirror and extended options (5 in total, extend left, right, etc).

It doesn’t do anything that I can tell, no output on projector.

I’m going to boot into a different Linux OS using a liveboot USB and see if anything changes.

BTW, here are a few of the dependencies I saw for the plasma-thunderbolt package. I presume they all were met if the package was installed?


I made no progress yesterday on this issue. Moreover the network problem recurred several times yesterday after I changed the IPv6 to “Ignored”. More about that in the other thread.

It occurred to me today that I had a very similar “problem” when I first tried to use my projector with this machine. The machine has 3 USB-C ports, and I was using the only 1 of those 3 that wasn’t Thunderbolt enabled. Once I moved the HDMI dongle to the other side of the machine it worked.

That isn’t the case this time, however the symptom is the same; it behaves just like there was no dongle attached. Both dongles with HDMI ports also have USB-3 ports which work, so the machine “sees” the dongle.

It’s as though the Thunderbolt is disabled, but there is nothing in the BIOS that provides a way to disable it. I’m confident support for Thunderbolt is built into the machine’s native BIOS for 2 reasons: 1) there is a function meta key used to activate features like airplane mode, keyboard & display brightness, sound AND display extending, mirroring modes. Using that display mode key overlays a graphic on the screen to select one of several display configurations.

I’m beginning to wonder if there is a hardware malfunction internal to the machine.

I booted MX-Linux from a live USB stick, also a KDE variant and it behaved the same as Manjaro. I haven’t tried OpenSuSE yet tho. I will take a few hours to backup Manjaro and restore OpenSuSE from backup due to drive being encrypted, forcing the need to backup entire disk space. I would like to avoid that, but I’ve already spent far longer trying alternatives.

2 more things I will try: 1) install the newest BIOS firmware. There is one newer version available. 2) Install Windows 10 (gag), since that is the only OS Asus officially supports. If it fails under Windoze I could get factory support, and at least determine if the hardware or the op sys / software is the cause of the problem.

I installed the newest BIOS firmware but still doesn’t detect either dongle.

Watching this video by a red hat guy gave me some things to try.

  1. cat /proc/modules | grep bolt:

    wmi 36864 3 asus_wmi,wmi_bmof,intel_wmi_thunderbolt, Live 0xffffffffc0604000
    So it appears the kernel was compiled with module support for Thunderbolt. Support goes way back to version 4.x kernels.

  2. ls /sys/bus/thunderbolt:

    no such path (no thunderbolt under /sys/bus)

  3. ps aux | grep -i bolt:

    Looking for the boltd daemon. None found. According to the video boltd is the interface for user space apps.

  4. check if boltctl command line tool available; yes it is

    boltctl list (returns nothing)

  5. boltctl monitor produces:

Bolt Version : 0.9
Daemon API : 1
Client API : 1
Security Level: user
Auth Mode : enabled

However plugging the Asus dongle in shows no change, despite the USB 3 port on it working. When I plug in the Aerofara dongle in I get:
1601609605970663 Probing started
1601609609974762 Probing done
However, a subsequent boltctl list still shows nothing.

The always useful Archwiki was not so much for this. It wouldv’e been a good place to start tho. I already found that info by the time I landed there (Thunderbolt - ArchWiki)