Can't get Broadcom BCM4360 PCI wireless adapter to work

I know this there is an issue with the realtek drivers, but I can’t get it to work. I’ve looked in google and in the forum, tried several things and in the end the thing still does not work.
About a year a go I installed manjaro for the first time and had the same issue, but after asking here I got it fixed by being told of the mobile phone USB tethering trick.
But now I can’t get it to work. Not to mention that I’m yet to fix the Radeon drivers…
I have dual boot PC and everything works fine on windows.So it’s not hardware issue.
So yeah…help

Did you install the drivers from the Hardware page of Manjaro Settings?

yes tried that, as well as drivers from pacman, and no luck.
The hardware page in the Manjaro Settings was the first thing I tried.Because I saw it right away when I checked the system settings.

OK I had issues with it too. Make sure everything is set to automatic in the NetworkManager application, with no DNS server configured at all. Reboot and see if it work.

Then if it doesn’t work, can you try to shutdown computer, unplug the RJ45 cable from your computer, wait 5 minutes, and reboot and plug back in the RJ45 cable to see if it then works when you boot again? Not fixing anything but it is to try to narrow down something.

You can check here too Network-8168 and network-8169 works really bad with my computer

I did not configure anything in the NetworkManager.So everything is on auto and no DNS settings or anything.
Shutting down the computer and unplugging the RJ45 is also not an option because I don’t have a RJ45 cable. The card is actually a PCI wireless adapter.Not an Ethernet one.
I just checked that thread link you posted, and yeah I also noticed that linux and windows didn’t agree on time zones. And I had to always turn off and on the windows automatic time zone button. But the rest of the stuff did not work for my machine. I checked windows and it does not have a “RealTimeIsUniversal” key. Also if I shut down windows and then boot Manjaro or just restart windows and the boot to Manjaro, makes no difference it’s still not working.

I didn’t know that the same chip could be wired AND wireless.

Also for the time, you can either set Linux to use local time, or windows to use UTC so this way the motherboard is set to the same time always.

ok so I set windows to UTC and Linux to local time.
nothing changed.Although now I get the correct time in windows and linux which is nice.

Can you post the output of inxi -N

And so you have the same time difference, the other way around.

no time is exactly the same as in windows no difference

Ok then you live in the UTC timezone, and didn’t need that change then?

As far as I know, Linux stores time in UTC time, and Windows in local time, so it is the same only if your local time is UTC. So if you have Linux in local time and Windows in UTC, it is exactly as before, the other way around.

no actually I’m in EET…or whatever it is called…while I was looking how to change to local time in Linux I found the timedatectl command and here is the output:

               Local time: Mon 2020-11-30 19:32:23 EET
           Universal time: Mon 2020-11-30 17:32:23 UTC
                 RTC time: Mon 2020-11-30 17:32:23    
                Time zone: Europe/Sofia (EET, +0200)  
System clock synchronized: yes                        
              NTP service: active                     
          RTC in local TZ: yes       

Also sorry about not posting the inxi stuff from the get go. To be honest I forgot the command. But here it is

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network Adapter driver: bcma-pci-bridge 

but I think I saw something…which if it is what I think it is…I’m a complete moron, and that maybe the broadcom device is actually the one I should be looking for drivers.

If thats the case, see here:

Can’t get what to work? You still haven’t said what the issue is.

Wrong driver then. This is your wired adapter:

This is your wireless adapter:

yes I guess, I’ve installed, b43-firmware and b43legacy-firmware, and the wifi started working again. Thanks!
Thank you to @omano for helping out as well.
As to @Yochanan, really you aren’t helping much. If anything your comment sounds a bit snobbish. I’m really sorry that I’m an average user of another OS where I don’t spend weeks trying to find and setup the proper driver for my hardware.
That being said now I have to spend a day or two to figure out how to setup my Radeon rx570.

Here is an article about the AMD GPU. I don’t have this hardware and haven’t tested. They are using yay, you can use pamac as well:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.