Can't get AMD VLK working


I installed amdvlk & lib32-amdvlk from the official repos via the package manager on Manjaro KDE (Stable branch). I’ve rebooted my computer a couple of times but it seems like the icd files aren’t registering with the system.

ls /usr/share/vulkan/icd.d/
amd_icd32.json intel_icd.i686.json radeon_icd.i686.json
amd_icd64.json intel_icd.x86_64.json radeon_icd.x86_64.json

As far as I’m aware, what should also be showing up is amd_icd32.json & amd_icd64.json which are located in /usr/share/vulkan/icd.d

I tried setting a game in Lutris to use AMD VLK by adding this to the environmental variables in the left column: VK_ICD_FILENAMES
And this in the right column: /usr/share/vulkan/icd.d/radeon_icd.i686.json:/usr/share/vulkan/icd.d/radeon_icd.x86_64.json

However, when launching the game, Lutris reports this:

info: AMD RADV NAVI10 (ACO):
info: Driver: 20.2.1
info: Vulkan: 1.2.131

So it seems that AMD VLK won’t work. This is the first time I’ve ever tried to use it so I’m not sure what I’m doing wrong here. Does anyone know?

Thanks :slight_smile: