Can't find Windows 10 boot partition after reinstall Manjaro

After reinstall manjaro, grub can’t find windows boot partition in my other ssd. I’ve already tried run os-prober and update-grub and, in /etc/default/grub, GRUB_DISABLE_OS_PROBER is false . I’ve too tried mount the windows partition (/dev/sda2) and run os-prober and update-grub, but nothing happened.

p.s.: sorry by my english, i’m brazilian.

Does it … exist?

sudo ls /boot/efi/EFI
1 Like

If you updated the bios, or if you created the bootable usb on another computer, maybe you somehow mixed bios and uefi installations (the reinstall being in different mode now).

1 Like

the result is this, the windows volume is still there, but it is no longer marked as bootable (it stopped being so after reinstalling manjaro)
Screenshot from 2024-02-02 21-43-12

I didn’t update the BIOS or change its settings, I just reinstalled manjaro, and before this, Windows boot worked. But, i created the bootable usb on windows (in the same computer, the same windows than worked before reinstall manjaro)

Looks like there is no windoze in the ESP.
Is sda the windoze stuff?
Is windoze installed as EFI or legacy-bios?

  • If its Legacy-BIOS, then its different than Manjaro (installed as EFI), so they will never mix.

  • If EFI … then I must suppose the ESP is separate on sda.

Either way you chose to create the dual-boot in such a way that they cannot coexist seamlessly.
There is no way this setup (whichever one) will ever have grub show you both options on boot.

In both scenarios you should be able to select them from your BIOS … but in the case of EFI+Trad you may need to do some extra things like flip ‘legacy boot mode’, etc.

I suppose theres one more possibility.
The third option I guess is that windoze is EFI but has no ESP because it was inadvertently deleted. :person_shrugging:
This last case would mean you need to reinstall the windoze bootloader somehow … which you will need to consult the microsoft documentation about.

1 Like

The device is an SSD that contains only Windows. I understand the difference between efi and bios, and windows was under efi, so much so that I already had a manjaro and that same windows coexisting in different drives under efi, the only thing I did was reinstall manjaro and windows didn’t boot. In fact, the bootable USB was made in this old Windows that now no longer works.

So … you can hope that the ESP is simply that sda1 and you didnt re-use it (created a new ESP on the nvme) … if thats true … then you need only select it from the BIOS screens. But you still wont be able to ‘update-grub’ to get windoze to show.

1 Like

Yes, the text added by you after your edit is also my guess for this issue. I just didn’t understand how this happened during the manjaro installation, since windows is on a separate disk

sd1 is a microsoft reserved partition. It has just 16MB

Then … yes, sad days.
Besides some sort of recovery operation … the original windoze ESP is gone.

Its OK to have win+lin share the same ESP … but, for example, during linux install you would select but not format the existing ESP.

For your situation - luckily it does not mean your data is gone. But you will still need to install the M$oft bootloader again somehow in order to start windoze.

ex, first hit on ddg;

1 Like

and, after reinstall manjaro, the windows boot candidate not is showed on the bios boot menu

No problem, this window was only used for games, nothing important there.