Can't find in pamac or pacman

I am trying to open an app but it’s say :

guidgen-gui: error while loading shared libraries: cannot open shared object file: No such file or directory

i search for this package but i can’t find it !!

It would be more helpful if you told us what application that is, where you got it, how you installed it, and what manjaro branch you are on ─ Stable, Testing or Unstable.

Here on my Stable system, libwx_baseu bears version 3.0.

It’s part of the package called
but the version required by your app is a higher one than what is available via the repositories
current is:
not what your package apparently depends on

the package is a C++ gui framework
i clone it using git and install it using it’s own install function

i have extra/wxgtk-common installed !
i don’t know where is the problem now

it’s the wrong version - for your software
you need a different one, a higher one
(that is what the error message indicates)

How to find it and satisfy that?
I don’t know.

Which one?

xtd , it’s a new gui framework
so i ask the developer of this package and he say :

> At the moment xtd uses wxwidgets and gtk3 as backend.
> I suspect that you have a packet and dependency problem on your linux system.... 
> maybe you have a wxwidgets library in an older version and/or installed in shared library. 
> Xtd only uses version 3.1.5 of wxwidgets in static.
> Delete the useless paket and try again.

but when i delete the wxwidgets that i have i still get the same error

you (obvious to me) need some version of wxwidgets - you can’t just delete it and still expect the app to work without it
… you need that version the dev made it depend on:

version 3.1.5
1 Like

The version is included with the framework the developer say that i may need to reinstall it