Can't find applications after installing them anywhere

after installing applications from pamac cli and gui, the gui shows that the application is installed but i cannot find it in the application launcher or anywhere else by search even though pamac shows it is installed.

edit: can run the application by launching it from cli

Welcome to the forum! :vulcan_salute:

Without knowing which applications you are referring to, it is highly likely that the applications you installed were command-line utilities, not GUI applications, and as such, they won’t get added to any application launcher menus.

Could you be more specific about which applications you are referring to, and whether they were from the official Manjaro repositories, or from the AUR, or installed via Snap or FlatPak, or as an AppImage?

i installed visual studio code from AUR and discover from the official repos

You are running KDE Plasma. Have you tried logging out and logging back in?

yes, didn’t work also restarted the system many times and that also didn’t work

Was the Visual Studio package visual-studio-code-bin, visual-studio-code-cli-bin or visual-studio-code-insiders-bin?

I don’t know why discover was not added to your menu, though — I don’t use it.

If you’ve installed the open source variant (Code - OSS) just search for ‘code’ or OSS.

visual-studio-code-bin

i can use the application perfectly by launching it from the terminal but having a shortcut would be better :grinning:

i installed the official binary release from AUR

Well, you could always manually create a launcher for it, but it is of course puzzling why this was not included in the PKGBUILD. And discover should definitely come with a .desktop file. :thinking:

Is your system fully up-to-date?

Your system is up to date.

this is what i got after running the “pamac checkupdates -a” command

You do have an open source variant of it in the official repository (community/code) - sudo pacman -S code - which is better than AUR (unrelated to this problem), unelss you really need the MS variant (I forgot the details, there’re some limitations with what you get by default but all can be easily worked around, I think).

i need the MS variant due working with extensions. some of the extensions are not available in open source variant

I forgot all the details, as I have it all setup so was a while since I did that, but read about it online but there is a fix for that, as it’s only the marketplace ‘links’ that are missing and those files can be patched on the machine. Here is one link fast (AUR (en) - code-marketplace) but something along those lines (I think I’ve used something else but similar), so you pretty much can have a normal marketplace. At least you should research, try, depending on what you need, as it pays off having something in the official repo instead of AUR.

You may want to try to run

$ update-desktop-database

Maybe you need to re-login afterwards.

From the PKGBUILD file here
https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=visual-studio-code-bin

The relevant .desktop files seem to get moved to the right places.

3 Likes

Thank you! This worked and all the applications are now showing in application launcher and other searches.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.