Can't enable blur/transparency effect

I’m using manjaro kde.

I’m using sweet kde as global theme and sweet transparent toolbar as kvantum theme.

I have set application style and color scheme to kvantum

I have checked and enabled blur on workspace behavior > desktop effects

My global display scale is 100%

Also using Force blur kwin script (after checking that blur not working with previous options)

I want max blur /transparency effect on everything as shown in the theme.
I have tried everything suggested by othes in various forums /posts but nothing helping me enabling the blur effect.
Please help

First of all, the availability of translucency and blur are specific to the chosen theme. If a certain aspect of the window is opaque ─ i.e. not translucent ─ then there’s nothing you can do about that, because it’s part of how the theme was designed.

If you truly want as much translucency as possible, then look into the Glassified themes at store.kde.org.

I also recommend not installing any global themes, but instead installing the components of the themes ─ e.g. window decorations, Kvantum application style, icons, mouse cursors, wallpapers, et al ─ all separately, because quite often, global themes introduce compatibility issues, especially if the theme is already old.

Secondly, make sure that your compositor is enabled… :arrow_down:

System Settings → Hardware → Display and Monitor

For the best results, you should choose OpenGL 3.1. Also note that the blur effect does not work with the XRender setting.

1 Like

ok, so I checked the compositor which said opengl was crashed so it turned it off.
I re-enable it again and there is blur effect on everything I wanted but it’s minimal.
Like the blur is very very low, is there any way to increase the translucency /blur effect?

Edit : solved it by Changing the reduce window opacity value in kvantum.

Thank you very much for the help

1 Like

One more thing. I have the blur effect now, but it doesn’t look smooth. It looks noisy like a steamed transparent glass or something like that.
Is there any way to make the blur/transparency effect more smooth or. clearer?

Well, yes. In the same Desktop Effects section of System Settings where you increased the blur effect, you will also find a slider for the noise level. You can play around a bit with both sliders until you get the effect you want. :wink:

To put it briefly…

  • Blur increases or decreases the blur level itself.
  • Noise increases or decreases the optical distortion.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.