Can't dual boot on my HP 15-DB1061AU Laptop

I recently bought HP 15-DB1061AU, which is currently using two ssds. On M.2 SATA SSD, windows 10 is installed while on the 2.5 inch SATA SSD, Manjaro is installed. But whenever I boot the system, the system boots windows 10 and doesnot go to the GRUB boot menu. So currently, I am using boot options to boot Manjaro. Please help me in getting to boot to the GRUB menu.

Maybe check the boot order in your UEFI? It should boot the manjaro ssd first.

I have tried to change the boot order, but it changes back to Windows Boot Manager.

$ inxi -Fi
  Host: distroHopper Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 
  Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Laptop 15-db1xxx 
  v: Type1ProductConfigId serial: <superuser/root required> 
  Mobo: HP model: 85EA v: 51.21 serial: <superuser/root required> 
  UEFI: Insyde v: F.28 date: 05/08/2020 
  ID-1: BAT1 charge: 39.8 Wh condition: 41.2/40.9 Wh (101%) 
  Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP L2 cache: 2048 KiB 
  Speed: 1228 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1296 2: 1247 
  3: 1226 4: 1269 5: 1222 6: 1222 7: 1222 8: 1223 
  Device-1: AMD Picasso driver: amdgpu v: kernel 
  Device-2: Chicony ASM105X series type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati 
  unloaded: modesetting resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.37.0 5.7.19-2-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.7 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
  Device-3: AMD Family 17h HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.7.19-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: eno1 state: down mac: bc:e9:2f:bf:ce:94 
  Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter driver: rtl8723de 
  IF: wlo1 state: up mac: 70:66:55:b6:a6:8b 
  IP v4: type: dynamic noprefixroute scope: global 
  IP v6: fe80::3d9:d98b:c91e:45e7/64 type: noprefixroute scope: link 
  WAN IP: 
  Local Storage: total: 462.05 GiB used: 117.01 GiB (25.3%) 
  ID-1: /dev/sda vendor: Intel model: SSDSC2KW256G8 size: 238.47 GiB 
  ID-2: /dev/sdb vendor: Western Digital model: WDS240G2G0B-00EPW0 
  size: 223.58 GiB 
  ID-1: / size: 50.00 GiB used: 18.80 GiB (37.6%) fs: btrfs dev: /dev/sda2 
  ID-2: /home size: 179.99 GiB used: 98.20 GiB (54.6%) fs: btrfs 
  dev: /dev/sda4 
  ID-1: swap-1 type: partition size: 8.00 GiB used: 13.5 MiB (0.2%) 
  dev: /dev/sda3 
  System Temperatures: cpu: 45.4 C mobo: 20.0 C gpu: amdgpu temp: 45 C 
  Fan Speeds (RPM): N/A 
  Processes: 306 Uptime: 57m Memory: 5.82 GiB used: 1.80 GiB (31.0%) 
  Shell: Bash inxi: 3.1.05

Has Windows 10 maybe “Fastboot” activated?

Some UEFI firmware has this “feature”. My usual trick is to rename the Windows one to something else while the GRUB (or rEFInd or anything else) one to “Windows Boot Manager”, that will fool the firmware to think it’s booting Windows Boot Manager.

No, the fastboot isn’t activated. Actually, Windows 10 is installed using GPT Partitioning Scheme while Manjaro is installed using MBR Partitioning Scheme, do you think this is the reason the system can’t boot to GRUB menu automatically?

YES and again YES… Jackpot! :smiley:

Both need to be GPT and using UEFI. They need to us the same. :wink:

Okay, I will reinstall Manjaro using MBR Partitioning Scheme. Let’s see if it rectifies the problem that I am having.

??? You installed Manjaro on MBR and legacy BIOS or? And now do it again?

Install it on UEFI and GPT like WIndows.

I installed it UEFI+MBR. This time I will install it UEFI+GPT.

I actually want to save the config files for KDE. Which folders should I backup before reinstalling Manjaro?

No idea, I use XFCE, I would backup the whole home folder or at least the hidden folders/files.

Turns out I was already using GPT for Manjaro. What to do now?

I installed rEFInd and can boot to both operating systems without any errors, but I am still not able to make the rEFInd Boot Option to be the default.

If both are installed as on UEFI and GPT, then try this:


You could have a list like this:

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0000,0002,0003
Boot0000* windows
Boot0002* manjaro
Boot0003* UEFI OS

and then change the boot order like this:

sudo efibootmgr --bootorder 0002,0000,0001

Well if nothing helps, i would overwrite the windows bootloader with grub:

sudo grub-install /dev/sda # Have to be the Windows SSD
sudo update-grub

But then,

But then how will I be able to boot windows if I am overwriting windows boot manager with GRUB.

Can you please elaborate more on that?

It doesn’t overwrite the boot partition, but the first bytes of the SSD which are needed to boot. It will write that it start grub and never the windows bootloader. But you can choose windows in grub anyway.

Okay, let me check that.