Can't download other color scheme in Konsole

Greetings everyone !
I installed Manjaro on 2 different laptops (ASUS mini-PC PN51 & MSI gl62vr 7rfx) and have the same problem in both. I want to change the appearence of the color scheme of the Konsole. When I go to settings > Edit Current Profile > Appearance and clic to download other theme, the page appear but I can’t clic on it neither write a theme name in the search section. It is written above “the content available here has been uploaded by users like you, and has not been reviewed by your distributor for functionality or stability”. However, I can download icon, theme etc. in the System Settings for Plasma and system (it works here but there is nothing here for Konsole). Moreover, I tried with Third AUR activated in the software center, with no better result.

What am I doing wrong ? I’ve never had this problem on non-Arch Linux :/. Is it smoething to fixe with Manjaro (or Arch more generally ?) or did I fail something ?

Thanks for helping me

I am a novice when it comes to KDE but I do know the default profile is read-only.

You will need to create a new profile - then edit that profile.

But you also need the knewstuff package installed to be able to to use the Get New… function.

Hi, thanks for your answer. I already edited a new profil with my name, change the default zsh with bash etc. I can change color with the proposed ones (ex. breeze, solarized etc…) but not use Get New to download new ones. I checked in the software, knewstuff is installed (v.5.93.0-1). I use the last LTS kernel Linux 5.15.38-1. :confused:

Can’t say what is the issue as it works for me.


Edit - just a thought - I noticed the newstuff thing is opening below the konsole window - most likely unintentional sideeffect of kdenewstuff - so if you terminal is full screen the newstuff window could be hidden below.

Right-click in konsole, choose either New Profile or Switch Profile and configure the profile as you like. Konsoles widow trimmings etc will follow the plasma scheme, but if you want to change the shell itself, you’ll need to modify the konsole profile.

Yeah I noticed that the new window appeard below. What I mean is : I can open the windows with new theme, but the windows is not “clicable”, I can’t clic on it, nothing happens, I can’t clic in the search bar to enter the name of the theme I look for… very strange behavior, and same problem on 2 different computer. I’m new on Manjaro (want to test an Arch), I used Ubuntu, Kubuntu, KDE Neon and Mint on 4 computers, and never had that :confused:

Hi thank, I know all that, I have my profile (even several in fact), change my shell (I use bash insted of the default zsh), I changed everything I need in the profile, but the scheme color I want that I can’t download. I can open the page, but I can’t click on it to select one theme or write the theme I want in the search bar

I can reproduce and confirm. The Download New Stuff window pops up just like it is supposed to, but the parent Edit Profile window never seems to give up the focus. Window controls partially work: I can minimize and maximize the Download window, but cannot close it.

Sounds similar to a post on KDE bugtracking system from 2022-04-13:

1 Like

And so is there a solution ? I am “glad” (not for you ahah) that I am not the same to have this issue :confused:

@Richben You can download manually from KDE store and move the downloaded file into ~/.local/share/konsole/
There are also some in the AUR ready to download.

Other than that you will have to wait until the bug is fixed upstream.

1 Like

OK thank you :slight_smile:

Hi, I know this is the Manjaro forums but I ran in to a similar issue on EndeavourOS.

It is exactly as you describe. Using konsole (or yakuake too for that matter), I can create a profile and edit that profile like you’d expext. Once I click the ‘get new’ button under the appearance tab, the ‘get new stuff’ window opens, yet I can’t do more than drag it around, even the close button on the top right doesn’t work.

What I think is happening is the parent window (edit profile window) somehow keeps the focus instead of passing it to the child window (theme download window). so far haven’t found a fix yey. my system is fairly fresh, considering doing a reinstall to see if that fixes things (reinstall didn’t work)