Can't double click to open files (LibreOffice)

Hello everyone, I have a little problem with LibreOffice that I hope someone can help me with:

When I try to open files with LibreOffice by double clicking on them (docx, pptx, etc) I get an “error code 100 unknown” (not an exact translation as my system is on Spanish), however if I first launch for example, Writer, and then open the file, I get no errors and can open it normally.

I noticed the libreoffice icons on /usr/share/applications are flagged by a orange exclamation mark, but I don’t know how to fix it

 System:
  Kernel: 5.4.64-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=831e6f1f-ee62-4cec-b0e7-e358b88f556d rw quiet apparmor=1 
  security=apparmor resume=UUID=d743d72f-d222-4389-93a5-a2a0755f72be 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 81FB v: 330S-15ARR serial: <filter> 
  Chassis: type: 10 v: 330S-15ARR serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: 31900002 WIN serial: <filter> 
  UEFI: LENOVO v: 7WCN37WW date: 05/22/2019 
Battery:
  ID-1: BAT1 charge: 26.6 Wh condition: 26.8/30.0 Wh (89%) volts: 8.2/7.4 
  model: LENOVO BASE-BAT type: Li-poly serial: <filter> status: Unknown 
  cycles: 214 
CPU:
  Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 11 (17) 
  stepping: N/A microcode: 810100B L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 19969 
  Speed: 2222 MHz min/max: 1600/2500 MHz boost: enabled Core speeds (MHz): 
  1: 2033 2: 2150 3: 1880 4: 1898 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Lenovo driver: amdgpu v: kernel bus ID: 03:00.0 chip ID: 1002:15dd 
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus ID: 3-1:2 
  chip ID: 174f:2426 serial: <filter> 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu 
  FAILED: ati unloaded: modesetting alternate: fbdev,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.64-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.7 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 03:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
  alternate: snd_pci_acp3x bus ID: 03:00.5 chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.4.64-1-MANJARO 
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ce v: N/A modules: 8821ce port: 2000 
  bus ID: 01:00.0 chip ID: 10ec:c821 
  IF: wlp1s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 16.09 GiB (0.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: LDM2 scheme: GPT 
Partition:
  ID-1: / raw size: 195.31 GiB size: 191.25 GiB (97.92%) 
  used: 11.35 GiB (5.9%) fs: ext4 dev: /dev/sda7 
  ID-2: /home raw size: 1.33 TiB size: 1.31 TiB (98.36%) used: 4.75 GiB (0.4%) 
  fs: ext4 dev: /dev/sda8 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.01 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 67.6 C mobo: N/A gpu: amdgpu temp: 67 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 224 Uptime: 1h 36m Memory: 6.76 GiB used: 2.60 GiB (38.4%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1276 lib: 354 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

Error libreoffice
office

Please provide the full output of the following commands:

export LANG=C
xdg-open /path/to/file.odt
strace -e trace=open,close,read,write,connect,accept /usr/bin/libreoffice --writer /path/to/file.odt

:innocent:

  1. Check if you have this option enebled:
    https://i.imgur.com/gsjrz6u.png

  2. If didn’t help, in system settings → applications check if you have for odt file proper application assigned.

  3. Looks like it doesn’t have executable rights. Is your username “nobody”? Because it would be strange if there was any file in Linux without owner. It should have your username as user and you should see an option to make it executable.

1 Like

Right-click on the file, go to properties, click on “Filetype Options” (or something similar). On the bottom, click add, choose the application, move it to the top, apply and ok.

EDIT: you should be able to do this with the “Open with…” right-click option, but, for some reason, sometimes you have to do it like this.

1 Like

thank you for your reply:

  1. I didn’t had it enabled, I enabled it but it didn’t work
  2. Writer does appear at the top of the list
  3. no, there’s no user on the computer with the name “nobody”, I don’t know why it’s set like that. could that be causing the issue?

Hello, I just tried this but Writer is indeed at the top of the list (for .docx and odt). I tried with open with and I get the same error.

I don’t know what could be causing this

This is interesting in the first place why in this folder some files don’t have root permission. Anyway, in such case I would reinstall libreoffice as a first step. It would probably help and take you less time than looking for help.
But looking for help is also good because you can learn Linux this way.

I am just curious, did you install Manjaro and Libreoffice yourself or have it done by someone else?

Enlance means “Link” - I have the same, but User: root, Group: root.
In location /usr/share/applications I have:

Go to this folder and see permissions:
ls -l for all files
Compare what other files ownership right are.

For libreoffice only ls -l libre*

This gives me:

ls -l libre*
lrwxrwxrwx 1 root root 43 09-03 17:32 libreoffice-base.desktop -> /usr/lib/libreoffice/share/xdg/base.desktop
lrwxrwxrwx 1 root root 43 09-03 17:32 libreoffice-calc.desktop -> /usr/lib/libreoffice/share/xdg/calc.desktop
lrwxrwxrwx 1 root root 43 09-03 17:32 libreoffice-draw.desktop -> /usr/lib/libreoffice/share/xdg/draw.desktop
lrwxrwxrwx 1 root root 46 09-03 17:32 libreoffice-impress.desktop -> /usr/lib/libreoffice/share/xdg/impress.desktop
lrwxrwxrwx 1 root root 43 09-03 17:32 libreoffice-math.desktop -> /usr/lib/libreoffice/share/xdg/math.desktop
lrwxrwxrwx 1 root root 50 09-03 17:32 libreoffice-startcenter.desktop -> /usr/lib/libreoffice/share/xdg/startcenter.desktop
lrwxrwxrwx 1 root root 45 09-03 17:32 libreoffice-writer.desktop -> /usr/lib/libreoffice/share/xdg/writer.desktop
lrwxrwxrwx 1 root root 49 09-03 17:32 libreoffice-xsltfilter.desktop -> /usr/lib/libreoffice/share/xdg/xsltfilter.desktop

Change ownership to root with sudo chown root:root filename

If doesn’t work uninstall libreoffice with
sudo pacman -Rns libreoffice-frash
or
sudo pacman -Rns libreoffice-still
depending on what version you have. This should remove all related to libreoffice also configuration files in home -I think so. If you want to keep configuration files this should be I guess just -Rs
You can check it with pacman -Rns -h
Make sure those files were removed and install again.

By the way, you can run Plasma applications with other language by:
export LANG=en_GB.UTF-8; dolphin
or
export LANG=en_US.UTF-8; dolphin

Please provide the output of ls -la in the path of the desktop files.

Thank you everyone for your contributions, and I want to apologize to all of you for disappearing, but I was really busy at work and I completely forgot I made this post in the first place.

Good news is that somehow the latest manjaro update fixed the issue and libreoffice now works properly. On the other hand the same update made my panel/dock invisible, so I had to create a new post on the KDE section of this forum, but that’s another story.

once again, thank you all!

1 Like