Can't create partition on any of my disks

Hi, I wanted to completely switch from Windows to Manjaro after having a dual boot for some time now. However, I think I did something stupid and now I can’t boot in Windows nor Manjaro anymore. GRUB led me to a black screen when selecting Windows and a infinite loading screen on manjaro. After that, I tried other solutions with a USB stick. However, trying “automatic repair” with a Windows USB stick led me to a BSOD, and Manjaro couldn’t boot either. However, I can now boot in Manjaro with another USB stick, and I tried to install it but it gives me the same error message:

Create a new partition table (type: msdos) on ‘/dev/sdb’

Job: Create new partition table on device ‘/dev/sdb’

Command: sfdisk --wipe=always /dev/sdb

Here’s my system with inxi -Fza:

  Kernel: 6.1.30-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=fr tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2213 quiet
    systemd.show_status=1 splash driver=free nouveau.modeset=1 i915.modeset=1
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: Z590-A PRO (MS-7D09) v: 1.0
    serial: <superuser required> UEFI-[Legacy]: American Megatrends LLC. v: 1.30
    date: 09/06/2021
  Info: model: 11th Gen Intel Core i5-11600K bits: 64 type: MT MCP
    arch: Rocket Lake gen: core 11 level: v4 note: check built: 2021+
    process: Intel 14nm family: 6 model-id: 0xA7 (167) stepping: 1
    microcode: 0x57
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2866 high: 3900 min/max: 800/4900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 3900
    4: 3900 5: 3900 6: 800 7: 800 8: 3900 9: 3900 10: 3900 11: 3900 12: 3900
    bogomips: 93924
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: none empty: DP-1, HDMI-A-1, HDMI-A-2, HDMI-A-3
    bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0380
  Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: PC Partner / Sapphire driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: HDMI-A-4,HDMI-A-5
    empty: DP-2,DP-3,DVI-D-1 bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
    temp: 49.0 C
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting
    alternate: fbdev,vesa dri: radeonsi,iris gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
    s-diag: 1055mm (41.54")
  Monitor-1: HDMI-A-4 mapped: HDMI-A-3 pos: primary,left
    model: LG (GoldStar) IPS277 built: 2012 res: 1920x1080 hz: 60 dpi: 81
    gamma: 1.2 size: 600x340mm (23.62x13.39") diag: 690mm (27.2") ratio: 16:9
    modes: max: 1920x1080 min: 640x480
  Monitor-2: HDMI-A-5 mapped: HDMI-A-4 pos: right model: LG (GoldStar) IPS
    FULLHD built: 2014 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 480x270mm (18.9x10.63") diag: 551mm (21.7") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon RX 480 Graphics
    (polaris10 LLVM 15.0.7 DRM 3.49 6.1.30-1-MANJARO) direct-render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: PC Partner / Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  API: ALSA v: k6.1.30-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Ethernet I225-V vendor: Micro-Star MSI driver: igc v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 04:00.0
    chip-ID: 8086:15f3 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4.4:8 chip-ID: 0bda:8771
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel Device driver: ahci v: 3.0 port: 4060 bus-ID: 00:17.0
    chip-ID: 8086:43d6 rev: N/A class-ID: 0104
  Supported mdraid levels: raid0
  Device-1: md126 maj-min: 9:126 type: mdraid level: raid-0 status: active
    size: 1.82 TiB
  Info: report: N/A blocks: 1953519616 chunk-size: 64k
  Components: Online:
  0: sdb maj-min: 8:16 size: 931.51 GiB
  1: sda maj-min: 8:0 size: 931.51 GiB
  Device-2: md127 maj-min: 9:127 type: mdraid level: N/A status: inactive
    size: N/A
  Info: report: N/A blocks: 5552 chunk-size: N/A
  Components: Online: N/A Spare:
  0: sda maj-min: 8:0 size: 931.51 GiB state: S
  1: sdb maj-min: 8:16 size: 931.51 GiB state: S
  Local Storage: total: raw: 3.76 TiB usable: 1.94 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate model: FireCuda 530
    ZP2000GM30013 size: 1.82 TiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: SU6SM001
    temp: 36.9 C scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A01
  ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000BX500SSD1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 030
  ID-4: /dev/sdc maj-min: 8:32 model: USB Mass Storage Device
    size: 119.08 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
    fw-rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Alert: No swap data was found.
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 49.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1755
  Processes: 286 Uptime: 7m wakeups: 0 Memory: available: 15.43 GiB
  used: 1.81 GiB (11.7%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1211 libs: 330 tools: pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.27

and here’s what sudo parted -l gives me:

Model: ATA WDC WD10EZEX-08W (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start  End  Size  Type  File system  Flags

Error: /dev/sdb: unrecognised disk label
Model: ATA CT1000BX500SSD1 (scsi)                                         
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags: 

Model: USB Mass  Storage Device (scsi)
Disk /dev/sdc: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3855MB  3859MB  4194kB  primary               esp

Model: Seagate FireCuda 530 ZP2000GM30013 (nvme)
Disk /dev/nvme0n1: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  105GB  105GB  primary  ntfs         boot

Model: Linux Software RAID Array (md)
Disk /dev/md126: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start  End  Size  Type  File system  Flags

EDIT: I tried every MBR in the installer and it doesn’t change anything.

EDIT2: here’s the complete error log:

Am I completely screwed? Because I’m out of solutions at this point…
Thanks for the help.

so what exactly did you did?
and also seing:

maybe the disk is messed up?
was fast startup disabled in windows?
and also you are on RAID, so switch to AHCI, format completly the disk in question and try again installing manjaro…

I tried to completely remove Windows from my computer and I saw there was some file that were left on my HDD (my OS were installed on my SSD), I thought that they weren’t important, so I deleted them
And that’s exactly where my problems started
As for fast startup, it was disabled until now

and also you are on RAID, so switch to AHCI, format completly the disk in question and try again installing manjaro…

Now, I have to figure out how to remove GRUB at the startup screen to completely remove any mention of Windows (which is now referred as Windows Vista for some reason) but you literally saved me, thanks a lot

Grub is actually part of Linux, so…
You actually need Grub if that’s installed using Manjaro, which it is IIRC…

  • You can use other boot loaders like systemd-boot etc also after you become more adept in using and configuring Linux later on…

Anyhow welcome to the world of nomore Micro$@$ :face_with_hand_over_mouth:

your windows was not completely removed, since manjaro detected it…
are you using uefi? post output from:
ls /boot/efi

I meant, remove the startup screen that asks me if I want to boot on Manjaro on Linux bc that’s pretty annoying
However, I found a solution by myself so it’s all good

Instead of marking your last reply as “the solution”, maybe care to actually provide your solution for reader in the future who come across these posts?

1 Like