Can't create bootable USB

Update on my current situation
Manage to get into my account cannot delete my first account which is very buggy and Effects my other account a usb have bad sectors now after trying to install
An os whilst starting up.
In Windows you can’t see anything whereas in Manjaros there are files of the os. I can’t move any files or just put them into the bin. I can’t even install another os into it.its like the usb just broke.

Can someone please find a solution to this issue. PLEASE

when partitioning usb in linux i get this error

Create a new partition (29.29 GiB, ntfs) on ‘/dev/sdb’
Job: Create new partition on device ‘/dev/sdb’
Command: sfdisk --force --append /dev/sdb

Failed to add partition ‘New Partition’ to device ‘/dev/sdb’.
Checking that no-one is using this disk right now … OK

The device contains ‘iso9660’ signature and it may remain on the device. It is recommended to wipe the device with wipefs(8) or sfdisk --wipe, in order to avoid possible collisions.

Disk /dev/sdb: 29.3 GiB, 31457280000 bytes, 61440000 sectors
Disk model:
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xde0ebce0

Old situation:

/dev/sdb2: Start sector 0 out of range.
Failed to add #2 partition: Numerical result out of range

Failed to add partition ‘New Partition’ to device ‘/dev/sdb’.
Create new partition on device ‘/dev/sdb’: Error
Create a new partition (29.29 GiB, ntfs) on ‘/dev/sdb’: Error

Why are you partitioning a USB stick intended for installing Manjaro, not to mention putting an NTFS filesystem on it?

The .iso file is a filesystem image and should be written to the USB stick block for block, not as a file.

If the USB stick is /dev/sdb ─ do make sure of that! ─ then you should do something like… :arrow_down:

dd if=/path/to/the/file.iso of=/dev/sdb bs=4096 status=progress

… and let it finish.

1 Like

Manjaro ISO is ext4 - windows cannot read ext4.

On Windows use Rufus - and don’t be alarmed that windows cannot show the files. If rufus don’t complain the stick is OK.

Because Manjaro ISO uses ISO9660 you cannot create a partition in the empty space - if you need a multi purpose stick read this article

If you need to repurpose your stick

1 Like

issues fixed thanks guys

How to fix it ?

Rufus is not an option here. It forces dd mode because of the strange, hybrid mode which “its creator have not made compatible with ISO/File copy mode”.

Not working with any computer I’ve tested it on. Writing the simpler image of another distribution like Fedora works everywhere.

I suppose there was a good reason to make it like so, but I would definitely suggest an easier image format if that is possible at all, I’m having the same problem every time when I can’t write the image from Linux.

PS: lately tested with Rufus 3.17p, no success.

EDIT: only viable option on Windows, you can boostrap the whole process with VirtualBox, which is quickly installed, and create a small VM to boot your .iso and write it on an USB:

  • install VirtualBox (or VMWare if you really must, but VirtualBox offers more options)
  • plug your USB key, maybe you need to format it first (especially if you tried to use Rufus before)
  • create a small virtual machine for Linux, for ex for Arch. No need for a big HD nor a lot of memory
    • in the virtual machine configuration, add a share to this USB key
    • add a shared directory where you can store the manjaro.iso file
    • use the same .iso file as booting image
  • start the virtual machine, it should boot the very image you’re trying to write
  • select your keyboard and locale if necessary
  • boot (with open-source drivers, doesn’t matter much)
  • open a terminal, don’t use the usual ctrl-alt-T which opens something weird by default, do alt-F2 and type xfce4-terminal (or equivalent in GNOME or KDE)
  • sudo lsblk to see what device is your USB key (or sudo fdisk -l, or …)
  • from there, use dd to write the image, and that’s it