Can't copy and paste file on samba share after some update

I can no longer copy and paste a file on a samba share (tried it on 2 different machines with up to date updated Manjaro). Creating, changing or deleting file work. Copying file from elsewhere to samba share also works but copying file from the same samba share to the same samba share doesn’t.

Bash hangs, zsh kills the process with zsh: killed cp -i, Dolphin hangs until killed.

Here’re my fstab mount options:


What has changed? I’ve tried downgrading samba and cifs-utils even to a previous year releases(though it worked well somewhere in the last months of 2023) with no success. What else can i look upon?

Kernel: 6.1.69-1-MANJARO arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.27.10 Distro: Manjaro Linux

========== EDIT ===========

I’ve found the problem. It’s the kernel update. Apparently there was some breakage because in 6.1.68 appears the bug an the last good version is 6.1.67:

linux61 6.1.67-2
linux61-headers 6.1.67-2

========= EDIT 2 ==========

I didn’t know there is a new LTS, 6.6.10 doesn’t have such bug.

Solved by kernel 6.6 LTS (as if by magic).