Can't connect to WPA2-PSK AES - keeps asking for password

inxi -Fazy
  Kernel: 6.1.34-1-MANJARO-ARM-RPI arch: aarch64 bits: 64 compiler: gcc
    v: 12.1.0 parameters: coherent_pool=1M 8250.nr_uarts=0
    snd_bcm2835.enable_headphones=0 snd_bcm2835.enable_headphones=1
    snd_bcm2835.enable_hdmi=1 snd_bcm2835.enable_hdmi=0
    video=HDMI-A-1:1920x1080M@60 smsc95xx.macaddr=DC:A6:32:CE:66:45
    vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000
    root=PARTUUID=aa7fddd0-02 rw rootwait console=ttyS0,115200 console=tty3
    selinux=0 quiet splash plymouth.ignore-serial-consoles
    smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 usbhid.mousepoll=8 audit=0
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro ARM base: Arch Linux
  Type: ARM System: Raspberry Pi 4 Model B Rev 1.4 details: BCM2835 rev: d03114
    serial: <filter>
  Info: model: N/A variant: cortex-a72 bits: 64 type: MCP arch: ARMv8 family: 8
    model-id: 0 stepping: 3
  Topology: cpus: 1x cores: 4 smt: N/A cache: L1: 320 KiB
    desc: d-4x32 KiB; i-4x48 KiB L2: 1024 KiB desc: 1x1024 KiB
  Speed (MHz): avg: 600 min/max: 600/1500 scaling: driver: cpufreq-dt
    governor: schedutil cores: 1: 600 2: 600 3: 600 4: 600 bogomips: 432
  Features: Use -f option to see features
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 mitigation: __user pointer sanitization
  Type: spectre_v2 status: Vulnerable
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: bcm2711-hdmi0 driver: vc4_hdmi v: N/A bus-ID: N/A
    chip-ID: brcm:fef00700 class-ID: hdmi
  Device-2: bcm2711-hdmi1 driver: vc4_hdmi v: N/A bus-ID: N/A
    chip-ID: brcm:fef05700 class-ID: hdmi
  Device-3: bcm2711-vc5 driver: vc4_drm v: N/A bus-ID: N/A chip-ID: brcm:gpu
    class-ID: gpu
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev dri: vc4
    gpu: vc4-drm,vc4_crtc,vc4_dpi,vc4_dsi,vc4_firmware_kms,vc4_hdmi,vc4_hvs,vc4_txp,vc4_v3d,vc4_vec
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Acer S241HL serial: <filter>
    built: 2014 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 2.1 Mesa 23.0.3 renderer: V3D 4.2 direct-render: Yes
  Device-1: bcm2711-hdmi0 driver: vc4_hdmi bus-ID: N/A chip-ID: brcm:fef00700
    class-ID: hdmi
  Device-2: bcm2711-hdmi1 driver: vc4_hdmi bus-ID: N/A chip-ID: brcm:fef05700
    class-ID: hdmi
  API: ALSA v: k6.1.34-1-MANJARO-ARM-RPI status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: bcm2835-mmc driver: mmc_bcm2835 v: N/A port: N/A bus-ID: N/A
    chip-ID: brcm:fe300000 class-ID: mmcnr
  IF: wlan0 state: dormant mac: <filter>
  Device-2: bcm2711-genet-v5 driver: bcmgenet v: N/A port: N/A bus-ID: N/A
    chip-ID: brcm:fd580000 class-ID: ethernet
  IF: end0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: pl011 driver: uart_pl011 bus-ID: N/A chip-ID: arm:fe201000
    class-ID: serial
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Device-2: pl011 driver: N/A bus-ID: N/A chip-ID: arm:serial0
    class-ID: serial
  Report: This feature requires one of these tools: hciconfig/bt-adapter
  Local Storage: total: 119.08 GiB used: 5.89 GiB (4.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SR128 size: 119.08 GiB block-size:
    physical: 512 B logical: 512 B tech: SSD serial: <filter> scheme: MBR
  ID-1: / raw-size: 118.61 GiB size: 116.69 GiB (98.39%) used: 5.84 GiB (5.0%)
    fs: ext4 dev: /dev/mmcblk0p2 maj-min: 179:2
  ID-2: /boot raw-size: 457.8 MiB size: 457.5 MiB (99.94%)
    used: 54.6 MiB (11.9%) fs: vfat dev: /dev/mmcblk0p1 maj-min: 179:1
  Kernel: swappiness: 60 (default) cache-pressure: 80 (default 100)
  ID-1: swap-1 type: zram size: 11.44 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 44.3 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 191 Uptime: 1h 8m Memory: available: 7.63 GiB
  used: 1.73 GiB (22.7%) gpu: 76 MiB Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 Packages: pm: pacman pkgs: 746
  libs: 196 tools: pamac Shell: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.27

I just installed Manjaro ARM KDE (Full) on a Raspberry Pi 4 (8gb).

The issue I’m having is it won’t connect to any WiFi with WPA2-PSK AES. I’ve seen something similar in several posts on Raspberry Pi forums, after doing a Google search, but I can’t seem to solve it with those; talking about wpa_supplicant and /etc/wpa_supplicant/wpa_supplicant.conf etc.

It sees the SSID for all three networks (2.4GHz, 5GHz and a 2.4GHz Virtual; more on that one in a second) and it tries to connect, but it just keeps asking for the password over and over again. Ethernet works fine.

If I set the 2.4GHz (Virtual) to WPA-PSK AES (so not WPA2), as a test, it connects fine.

Security in Settings > Connections > Wi-Fi > [SSID name of connection] > Wi-Fi Security Tab > Security: is set to WPA/WPA2 Personal for all my networks.

Is there something I need to do extra in order to get WPA2-PSK AES working?

Note: I realize the easy solution is to change all my security settings, but I’d like to keep it as is, since I have some range extenders and other devices already setup and working and it’s my understanding WPA2 is more secure than WPA or WEP.

Happy to provide any command output required to help troubleshoot.


Did you try this link?

Hey, thanks for the reply!

I did, in fact, give that a try; well, kind of. I only tried it in on Raspberry OS* and I couldn’t get past wicd part, since it’s no longer being developed and not found in the AUR and the changes suggested didn’t seem to work on their own

Where has wicd gone?

*I wanted to use CasaOS on the Pi and it suggested using Debian or Rasp OS and why I didn’t just go with Manjaro to begin with, but I prefer Manjaro either way, so thought I’d switch to see if that solved the issue.

But after switching to Manjaro, I ran into the same issue, so it seems to be an issue the Pi itself and wpa_supplicant and setting it up for WPA2 specifically (as that link suggests.)

I can try it again now, though, I don’t know what to use in place of wicd.

I have had a seemingly similar experience with a netgear nighthawk AP

If you have more than one band you should ensure the bands is named differently e.g.


It is possible to have same name for all - but your device may then try to connect arbitrarily and this will result in an endless request for password.

Thanks for the reply!

This is a Netgear R7000P, interestingly enough.

When you say “band” do you mean the SSID for each band? I have what amounts to MyWifi-2.4GHz and MyWifi-5GHz SSID so I always know which band I’m connecting to.

I’m running DD-WRT, if that matters (so I do have access to change things.)

Okay, I think I fixed it (although not exactly sure what was the root cause.)

So, as I have said above, I have a Netgear Router, but I forgot to mention that I’m also using a wireless range extender (ASUS RP-N12) set in AP Mode (so it mirrors and extends the same MyWiFi-2.4GHz connection throughout the house.) Now I noticed in Settings > Connections that if I change the BSSID to the router’s BSSID/MAC, it connects. If I change it back to the extender’s BSSID/MAC, it doesn’t and just keeps trying to connect or ask for password.

When I created the Virtual Device it was able to connect, but that led me to believe the issue was due to WPA2/WPA, since I had changed that at the same time, trying to narrow down an issue, but I think it was able to connect to the router the whole time, whether it was WPA or WPA2, either way; but not to the extender. Not realizing this, it sent me down a path trying to get WPA2 working, as described in all the RaspPi posts and the one linked above. But, that may have been a false lead.

Anyway, I updated the firmware on the extender (although it was the same version as before) and rebooted it. That may have fixed it, but I also changed the Channel on the Router to 6 and the Channel on the Extender to 11 and that may have fixed it.

I may play around with Channels a bit more, set the channels the same again and see if I can reproduce the issue and narrow it down to that.

Okay, changing channels to be the same doesn’t seem to matter, from all I can tell (at least as it relates to this issue.) With that, the only thing I can figure is that re-uploading the firmware fixed something on the RP-N12. Very odd, but that’s all I could come up with.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.