Can't connect to the internet

I’ve recently gotten interested in Linux and decided to install Manjaro in a dual-boot with Windows 10, both on separate SSDs. The dual-boot seems to work fine, but for some reason the internet doesn’t work at all in Manjaro. I try adding my router through Network Manager but nothing happens. I initially assumed it might be a driver issue with my PCIe wi-fi card (a TP-Link Archer T9E card), so I tried installing the broadcom-wl drivers, but that did nothing. I can’t even get online through USB tethering, even though the Network Manager can see it. It just shows up as “disconnected” with no option to connect.

Here’s my inxi output:

  Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=9d59a24a-8aec-47d5-8ec8-0f5f2c447707 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x 
  serial: <filter> UEFI-[Legacy]: American Megatrends v: 0908 date: 10/23/2015 
  RAM: total: 15.56 GiB used: 873.6 MiB (5.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-6500 bits: 64 type: MCP arch: Skylake-S 
  family: 6 model-id: 5E (94) stepping: 3 microcode: E2 cache: L2: 6 MiB 
  bogomips: 25599 
  Speed: 800 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c 
  flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: driver: nvidia 
  v: 460.73.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:13c2 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 driver: loaded: nvidia display-ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0") 
  s-diag: 777mm (30.6") 
  Monitor-1: DVI-D-0 res: 2560x1440 hz: 60 dpi: 118 
  size: 553x311mm (21.8x12.2") diag: 634mm (25") 
  OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 
  direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 
  class-ID: 0403 
  Device-2: NVIDIA GM204 High Definition Audio vendor: 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fbb 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel 
  port: f000 bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: N/A 
  modules: bcma port: e000 bus-ID: 04:00.0 chip-ID: 14e4:43a0 class-ID: 0280 
  Device-3: Microsoft Xbox 360 Wireless Adapter type: USB driver: xpad 
  bus-ID: 1-6:8 chip-ID: 045e:0719 class-ID: ff00 serial: <filter> 
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 7.28 TiB used: 2.15 TiB (29.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WDS500G2B0A-00SM50 size: 465.76 GiB block-size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 20WD 
  scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 500GB 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 2B6Q scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital 
  model: WD2003FZEX-00Z4SA0 size: 1.82 TiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 
  scheme: MBR 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 870 EVO 2TB 
  size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 1B6Q scheme: MBR 
  ID-5: /dev/sde maj-min: 8:64 type: USB vendor: Western Digital 
  model: WD My Book 1140 size: 2.73 TiB block-size: physical: 4096 B 
  logical: 4096 B serial: <filter> rev: 1003 scheme: MBR 
  Optical-1: /dev/sr0 vendor: ASUS model: DRW-24B1ST j rev: 1.00 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 465.76 GiB size: 457.38 GiB (98.20%) used: 7.48 GiB (1.6%) 
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 9d59a24a-8aec-47d5-8ec8-0f5f2c447707 
  ID-2: /run/media/elliot/My Book raw-size: 2.73 TiB size: 2.73 TiB (100.00%) 
  used: 2.14 TiB (78.5%) fs: ntfs dev: /dev/sde1 maj-min: 8:65 label: My Book 
  uuid: C6B89CABB89C9B8D 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  ID-1: /dev/sdb1 maj-min: 8:17 size: 100 MiB fs: ntfs label: System Reserved 
  uuid: D252C51452C4FE6B 
  ID-2: /dev/sdb2 maj-min: 8:18 size: 465.15 GiB fs: ntfs label: N/A 
  uuid: B0E0CF04E0CED030 
  ID-3: /dev/sdb3 maj-min: 8:19 size: 526 MiB fs: ntfs label: N/A 
  uuid: 56C859DBC859BA47 
  ID-4: /dev/sdc1 maj-min: 8:33 size: 1.82 TiB fs: ntfs label: WD Black 2TB 
  uuid: 90AE968BAE966A0C 
  ID-5: /dev/sdd1 maj-min: 8:49 size: 1.82 TiB fs: ntfs label: Games 
  uuid: 86D87AF0D87ADE3D 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: Samsung Galaxy A5 (MTP) type: Still Imaging 
  driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 04e8:6860 class-ID: 0601 serial: <filter> 
  Device-2: 1-5:7 info: Wacom PTH-651 [Intuos pro (M)] type: HID,Mouse 
  driver: usbhid,wacom interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 498mA 
  chip-ID: 056a:0315 class-ID: 0301 
  Device-3: 1-6:8 info: Microsoft Xbox 360 Wireless Adapter type: WiFi 
  driver: xpad interfaces: 8 rev: 2.0 speed: 12 Mb/s power: 260mA 
  chip-ID: 045e:0719 class-ID: ff00 serial: <filter> 
  Device-4: 1-13:9 info: Corsair K95 RGB Platinum Keyboard [RGP0056] 
  type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 500mA chip-ID: 1b1c:1b2d class-ID: 0300 
  serial: <filter> 
  Device-5: 1-14:10 info: Swiftpoint Z - Gaming mouse [SM700] type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 4 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 214e:0005 class-ID: 0300 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 2-4:2 info: Western Digital My Book Essential (WDBACW) 
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s 
  power: 8mA chip-ID: 1058:1140 class-ID: 0806 serial: <filter> 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 59 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 189 Uptime: 2m wakeups: 1 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: N/A Packages: pacman: 1052 lib: 295 flatpak: 0 Shell: Bash 
  v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.04 

Does anyone have any idea on what might be wrong? I’m getting extremely frustrated trying to fix this.

Hi and welcome to the forum!

Check this out which will help us helping you:

Could you please post the output of:
pacman -Qs broadcom ?

Can you connect with the network adapter Intel (cable) ?

My router’s too far away from my computer to connect to it via ethernet, so I can’t try it and see if that works.

Here’s my pacman -Qs broadcom output:

warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
    Broadcom 802.11 Linux STA wireless driver

Hmm, querying pacman’s database I don’t see any broadcom-wl package, but there’s a broadcom-wl-dkms package. How did you install broadcom-wl, because your inxi output says you don’t have a driver installed for your network adapter?

Can you connect to your wifi from the live media?

I just downloaded the package for the drivers through Windows, put it on my external hard drive, then went into Manjaro and installed it with the package manager.

And no, I couldn’t connect to the internet through the live media either.

Maybe try installing broadcom-wl-dkms and linux510-broadcom-wl (though it says it’s for BCM43142) and see if that works…

I tried installing broadcom-wl-dkms before but it required dkms, so I tried to install it only for it to require even more dependencies. I went and downloaded those as well, but then they required more dependencies and so on and so forth. And again, I can’t access the internet through Manjaro, so downloading all of that through Windows, rebooting into Manjaro, and then trying to install them seems to be my only option.

One more thing I can think of right now is trying a different kernel, e.g linux512, maybe it contains an updated driver (I don’t know how kernel development works, though)…

Have you tried other Linux distributions than Manjaro?

I haven’t tried running other distros yet, though I probably will just to see if the internet works better on any of them. And I’ll definitely try a newer kernel as well.

1 Like

Maybe this will have more answers: Broadcom wireless - ArchWiki

Also: Can't get wifi to work : Broadcom BCM4360 - #4 by Adutchman

So I just did something incredibly stupid and tried to install the Arch Linux version of the Linux kernel. I forgot that Arch and Manjaro use different versions of the kernel, so when I rebooted after installing, Manjaro just wouldn’t boot. Thankfully I was able to boot into the version of the kernel Manjaro came with using the advanced options on the boot screen and then uninstalled the Arch kernel. Now it boots fine. That said though, I can’t find any downloads for the Manjaro version of Linux 5.12, so I have no idea how I’d be able to install it without internet.

You can pick a mirror from here:
The kernels can be found in the “core” section.

Did you check the link in my post above?

I just tried the Manjaro version of kernel 5.12 and the exact same thing happened as with the Arch version. So it seems like 5.12 just doesn’t work on my machine.

I already looked at the Broadcom page on the Arch wiki but it didn’t really help. I saw the other link you posted as well and tried to blacklist the BCMA drivers, but Manjaro wouldn’t let me make a file in the modprobe.d folder.

It would help to know what the error output said.

You could give linux511 and linux513 a try.

Did you install the kernel headers for 5.12?

1 Like

Yeah, I probably should’ve been a bit more specific. Sorry about that. I went into the /etc/modprobe.d folder and saw there wasn’t a blacklist.comf file, so I tried to make one but the option to make a new file was greyed out. I’ll try using the command line to blacklist the BCMA drivers if changing the kernel still doesn’t work.

Neither 5.12 or 5.11 were able to boot, even with the headers installed. So either only 5.10 works on my machine or I’m just installing the kernels wrong. Hopefully it’s the latter. I also was able to blacklist the BCMA drivers through the command line, but that still didn’t seem to do anything.

I think your best bet would be to do a fresh install (to get rid of any original arch package/remnants you’ve installed previously) and try to establish a LAN connection to be able to use Manjaro’s package manager(s) and tools such as mhwd for kernel installation (and updating grub etc).

I’d also recommend to at least get familiar with Linux’ directory structure and basic terminal commands, since this is where the real magic happens. Here’s a collection of useful links: