Can't connect to samba after update; Service is running (2022-08-13++)

None of the suggestions here are working.

[global]
   workgroup = WORKGROUP
   netbios name = manj-073021
   dns proxy = no
   log file = /var/log/samba/%m.log
   max log size = 1000
   min protocol = SMB2
   max protocol = SMB3
   server role = standalone server
   ;passdb backend = tdbsam
   ;obey pam restrictions = yes
   ;unix password sync = yes
   ;passwd program = /usr/bin/passwd %u
   ;passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
   ;pam password change = yes
   map to guest = Bad Password
   name resolve order = lmhosts bcast host wins
   security = user
   map to guest = bad user
   guest account = guest
   usershare path = /var/lib/samba/usershare
   usershare max shares = 100
   usershare owner only = yes
   usershare allow guests = yes
   ;force create mode = 0070
   ;force directory mode = 0070
   ;load printers = no
   ;printing = bsd
   ;printcap name = /dev/null
   disable spoolss = yes
   show add printer wizard = no
   follow symlinks = yes
   wide links = yes
   unix extensions = no

[homes]
   comment = Home Directories
   browseable = no
   read only = yes
   create mask = 0700
   directory mask = 0700
   valid users = %S

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

[guest]
   comment = guest
   path = /tmp/
   public = yes
   only guest = yes
   writable = yes
   printable = no

and tried whitelisting suggestion and disabling apparmor…

~ sudo systemctl stop apparmor 

I’m just trying to share a folder in home directory: clicking in Dolphin and in cli.

~ net usershare add share /home/me/share comment Everyone:R guest_ok=y
net usershare add: cannot convert name "Everyone" to a SID. The transport connection is now disconnected..

8 posts were merged into an existing topic: [root tip] [How To] Basic Samba Setup and Troubleshooting

Stopping apparmor is not enough, you need to disable it (systemctl disable apparmor) and then restart computer.

1 Like

I see you said that up there. Thanks for checking back, it works.

I’m curious to see where this is at. I ran into it today and the only way to get around it was to disable apparmor.

You could put apparmor in complain mode:

sudo aa-complain /usr/bin/smbd

sudo aa-complain samba-dcerpcd samba-bgqd samba-rpcd samba-rpcd-classic samba-rpcd-spoolss

reboot and check status with sudo aa-status

Check out the section on apparmor here:

Yep, that seem to do it. Thank you again and take care.

1 Like