Can't connect to any WiFi, "mismatching interface name"

Hi, today when I wake up I found that I couldn’t connect to any WiFi, and the network manager just shows a blank page.
Then I tried to connect with nmcli connection up <network name>, and it has the following error:

Error: Connection activation failed: No suitable device found for this connection (device enp2s0 not available because profile is not compatible with device (mismatching interface name)

Does anyone know what the error is? I tried to search it up but I couldn’t find helpful information, and also the only package I installed recently is rslsync (Resilio Sync) but I don’t think it would affect anything?

Thanks! Will post the kernel version & manjaro version soon.

Edit: I am using Manjaro KDE 21.0.5 with linux kernel 5.12.2. My nmcli version is 1.30.4-3.
I tried to stop the service rslsync.service but it didn’t help.

Edit again: my inxi

  Kernel: 5.12.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=0047339c-e4a0-4197-83cf-524bbed69149 ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: i3bar wm: i3 4.19.1 vt: 1 
  dm: SDDM Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: GIGABYTE product: AERO 15-XA v: N/A serial: <filter> 
  Chassis: type: 10 v: y.y serial: <filter> 
  Mobo: GIGABYTE model: AERO 15-XA serial: <filter> UEFI: American Megatrends 
  v: FB09 date: 03/19/2020 
  ID-1: BAT1 charge: 94.2 Wh (100.0%) condition: 94.2/94.2 Wh (100.0%) 
  volts: 16.8 min: 15.2 model: GIGABYTE Aero 15 type: Li-ion serial: N/A 
  status: Full 
  RAM: total: 31.09 GiB used: 10.52 GiB (33.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: DE cache: L2: 12 MiB bogomips: 62431 
  Speed: 841 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 841 2: 831 3: 815 
  4: 897 5: 819 6: 833 7: 888 8: 1383 9: 835 10: 882 11: 899 12: 850 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep sgx sgx_lc smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Gigabyte driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300 
  Device-2: NVIDIA TU106M [GeForce RTX 2070 Mobile] vendor: Gigabyte 
  driver: N/A alternate: nouveau, nvidia_drm, nvidia bus-ID: 01:00.0 
  chip-ID: 10de:1f10 class-ID: 0300 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus-ID: 1-9:4 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 compositor: picom v: git-dac85 driver: 
  loaded: intel display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 94 s-size: 1037x583mm (40.8x23.0") 
  s-diag: 1190mm (46.8") 
  Monitor-1: eDP1 res: 3840x2160 hz: 60 dpi: 287 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.0.3 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 
  chip-ID: 8086:a348 class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.2-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.28 running: yes 
  Device-1: Realtek vendor: Gigabyte driver: r8169 v: kernel port: 3000 
  bus-ID: 02:00.0 chip-ID: 10ec:2600 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 vendor: Rivet Networks driver: iwlwifi 
  v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 1-10:5 chip-ID: 8087:0029 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 596.18 GiB used: 330.86 GiB (55.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: Samsung model: MZVLW128HEGR-000H1 
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: CXB73H1Q scheme: GPT 
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Intel model: SSDPEKKW512G8 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: 004C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 100 GiB size: 97.93 GiB (97.93%) used: 36.1 GiB (36.9%) 
  fs: ext4 dev: /dev/nvme1n1p5 maj-min: 259:10 label: N/A 
  uuid: 0047339c-e4a0-4197-83cf-524bbed69149 
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) 
  used: 332 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p4 maj-min: 259:9 label: N/A 
  uuid: 5E9C-5AD9 
  ID-3: /home raw-size: 155.18 GiB size: 151.75 GiB (97.79%) 
  used: 110.48 GiB (72.8%) fs: ext4 dev: /dev/nvme1n1p6 maj-min: 259:11 
  label: N/A uuid: b210047f-4dca-45ff-8a13-90ee6dace9c0 
  ID-4: /home/<filter>/Data raw-size: 201.64 GiB size: 201.64 GiB (100.00%) 
  used: 184.28 GiB (91.4%) fs: ntfs dev: /dev/nvme1n1p2 maj-min: 259:7 
  label: Windows uuid: 0434115234114856 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme1n1p3 maj-min: 259:8 label: N/A 
  uuid: 883abcc0-0c64-4825-bf23-8de2cf1e7f5e 
  ID-1: /dev/nvme0n1p1 maj-min: 259:2 size: 260 MiB fs: vfat label: N/A 
  uuid: BC25-83C7 
  ID-2: /dev/nvme0n1p2 maj-min: 259:3 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p3 maj-min: 259:4 size: 118.01 GiB fs: ntfs label: Windows 
  uuid: 52906B38906B2229 
  ID-4: /dev/nvme0n1p4 maj-min: 259:5 size: 980 MiB fs: ntfs 
  label: Windows RE tools uuid: 34EED574EED52EBC 
  ID-5: /dev/nvme1n1p1 maj-min: 259:6 size: 260 MiB fs: vfat label: SYSTEM 
  uuid: B80D-FE7B 
  ID-6: /dev/nvme1n1p7 maj-min: 259:12 size: 1024 MiB fs: ntfs label: WinRE 
  uuid: 4098292998291F42 
  ID-7: /dev/nvme1n1p8 maj-min: 259:13 size: 10.35 GiB fs: ntfs 
  label: RecoveryImage uuid: 32C42B9AC42B5F7B 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 info: Logitech G502 SE HERO Gaming Mouse type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 300mA chip-ID: 046d:c08b class-ID: 0300 serial: <filter> 
  Device-2: 1-4:7 info: SONiX USB Keyboard type: Keyboard 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 500mA chip-ID: 2efd:7812 class-ID: 0301 
  Device-3: 1-8:3 info: Elan Micro ELAN:Fingerprint type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 04f3:0c11 class-ID: 0000 
  Device-4: 1-9:4 info: IMC Networks USB2.0 HD UVC WebCam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter> 
  Device-5: 1-10:5 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029 
  class-ID: e001 
  Device-6: 1-11:6 info: Chu Yuen Enterprise USB-HID Keyboard 
  type: Keyboard,HID driver: hid-generic,usbhid interfaces: 4 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 1044:7a3f class-ID: 0300 
  serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 2-5:2 info: Realtek USB3.0-CRW type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 800mA 
  chip-ID: 0bda:0328 class-ID: 0806 serial: <filter> 
  System Temperatures: cpu: 72.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 377 Uptime: 3h 27m wakeups: 1 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1680 
  lib: 412 flatpak: 0 Shell: Zsh v: 5.8 running-in: kitty inxi: 3.3.04

Welcome to the forum!

Please take a look at the link below and update your post accordingly:

Thank you for letting me know! I included my inxi outputs now.