Can't connect one BT device and Wifi at the same time

        ~  inxi -Fnz                                                                                                   ✔
      Kernel: 5.19.7-1-MANJARO arch: x86_64 bits: 64 Desktop: KDE Plasma
        v: 5.25.5 Distro: Manjaro Linux
      Type: Laptop System: LENOVO product: 20NF0012US v: ThinkPad E595
        serial: <superuser required>
      Mobo: LENOVO model: 20NF0012US serial: <superuser required> UEFI: LENOVO
        v: R11ET31W (1.11 ) date: 11/20/2019
      ID-1: BAT0 charge: 44.1 Wh (100.0%) condition: 44.1/45.3 Wh (97.4%)
      Info: quad core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
        bits: 64 type: MT MCP cache: L2: 2 MiB
      Speed (MHz): avg: 1350 min/max: 1400/2100 cores: 1: 1400 2: 1779 3: 1230
        4: 1231 5: 1227 6: 1400 7: 1231 8: 1302
      Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
        driver: amdgpu v: kernel
      Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo
      Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
        loaded: amdgpu unloaded: modesetting gpu: amdgpu resolution: 1920x1080~60Hz
      OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.6 DRM 3.47
        5.19.7-1-MANJARO) v: 4.6 Mesa 22.1.7
      Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
      Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
      Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
      Sound Server-1: ALSA v: k5.19.7-1-MANJARO running: yes
      Sound Server-2: PulseAudio v: 16.1 running: yes
      Sound Server-3: PipeWire v: 0.3.57 running: yes
      Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
        driver: r8168
      IF: enp2s0 state: down mac: <filter>
      Device-2: Intel Wireless-AC 9260 driver: iwlwifi
      IF: wlp4s0 state: up mac: <filter>
      Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
      Report: rfkill ID: hci0 state: up address: see --recommends
      Local Storage: total: 2.73 TiB used: 133.1 GiB (4.8%)
      ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 1TB size: 931.51 GiB
      ID-2: /dev/sda vendor: Crucial model: CT2000MX500SSD1 size: 1.82 TiB
      ID-1: / size: 883.84 GiB used: 52.39 GiB (5.9%) fs: ext4
        dev: /dev/nvme0n1p2
      ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
        dev: /dev/nvme0n1p1
      ID-1: swap-1 type: partition size: 32.19 GiB used: 0 KiB (0.0%)
        dev: /dev/nvme0n1p3
      System Temperatures: cpu: 64.0 C mobo: N/A gpu: amdgpu temp: 63.0 C
      Fan Speeds (RPM): fan-1: 0 fan-2: 0
      Processes: 278 Uptime: 22m Memory: 29.26 GiB used: 3.33 GiB (11.4%)
      Shell: Zsh inxi: 3.3.21

When I connect to my wifi, it works great. When I add my BT headphones it works ok for a very short time then the NetworkManager seems to restart then loses only my wifi SSID. As soon as I disco the bluetooth headphones the wifi starts working again. It works fine with the headphones by themselves but won’t connect to any wifi.

5.10.141-1 LTS and 5.15.65-1 LTS also fail in the same way.

This does not happen in windows, but I never like using it. Other BT devices don’t seem to cause the same issue, nor do the headphones cause issues when connected to my phone right next to the laptop. It seems like it’s only these headphones with the wifi connected and only on linux.

I’m not seeing any relevant stuff in dmesg other then it not associating, but I already knew that:

    [ 1604.167413] wlp4s0: authenticate with 28:87:ba:87:57:76
    [ 1604.167439] wlp4s0: bad VHT capabilities, disabling VHT
    [ 1604.167441] wlp4s0: 80 MHz not supported, disabling VHT
    [ 1604.174022] wlp4s0: send auth to 28:87:ba:87:57:76 (try 1/3)
    [ 1604.213914] wlp4s0: authenticated
    [ 1604.216557] wlp4s0: associate with 28:87:ba:87:57:76 (try 1/3)
    [ 1604.489847] wlp4s0: associate with 28:87:ba:87:57:76 (try 2/3)
    [ 1604.613230] wlp4s0: associate with 28:87:ba:87:57:76 (try 3/3)
    [ 1604.773230] wlp4s0: association with 28:87:ba:87:57:76 timed out

Anybody have any ideas? Let me know if you need more info

The router has probably a problem with random mac addresses…

echo "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/random-mac-address.conf
sudo systemctl restart NetworkManager

This seems to working… tentatively. Will mark as solved, thanks a lot

Nope that worked for a little longer then normal, but didn’t solve it

I will add here that after connecting the BT headphones NetworkManager gets stuck on “Configuring Interface”

    ~  cat /etc/NetworkManager/conf.d/random-mac-address.conf                                               ✔  3s 

I don’t know if this is related but when I am on battery power my external usb mouse doesn’t work. Starting up on battery gives me about a minute of working USB, but then it stops working. If I start the computer plugged in it will work until it’s unplugged. Then the USB will work for a minute then stop. No amount of unplugging the USB and replugging fixes this.

If I plug in power after the USB stops working, the USB does not start working. Although the mouse still shows in lsusb even when it’s not working. The trackpad and nipple-mouse still work when the USB isn’t working.

Also, just saw these in dmesg on an unplugged boot:

[    9.444512] Bluetooth: hci0: Bad flag given (0x2) vs supported (0x1)
[   35.799386] xhci_hcd 0000:05:00.4: WARNING: Host System Error
[   36.002539] Bluetooth: hci0: sending frame failed (-19)
[   36.299554] xhci_hcd 0000:05:00.3: WARNING: Host System Error
[   37.002822] Bluetooth: hci0: sending frame failed (-19)

These errors do not show up when plugged in. There are no real options in BIOS for power management other then CPU power states.

Also for completeness:

    ~  rfkill list                                                                                               ✔  3s 
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

I did also do this with no help: Network configuration/Wireless - ArchWiki