Can't connect NetworkManager openconnect

Could you please give an advice how to configure VPN connection by user interface of OS.
I can do it from console by command like this:
sudo openconnect MyVPNAddress
echo "MyPassword" | openconnect MyVPNAddress --servercert pin-sha256:MyServerCert --authgroup MyServerGroup -u MyUsername --passwd-on-stdin
I can also connect from Windows 10 using Cisco AnyConnect Secure Mobility Client.
But I can’t connect by ui of Manjaro. I’ve tried several options. For example when I use vpnc without GroupPassword, it doesn’t connect and returns message:

sending new secrets to the plugin failed: GDBus.Error:org.freedesktop.NetworkManager.VPN.Error.InvalidConnection: The request could not be processed because the requested “IPSec secret” information was not provided.

(I watch logs with command journalctl -f _COMM=NetworkManager)
When I put there a GroupPassword it says that it is connected, but websites are not available and after 30 seconds it disconnects with message “dbus: failure: connect-failed”
I’ve also tried different types of connection but no success. I have this options in VPN settings menu:

  • Array Networks Compatible VPN (openconnect)
  • Cisco AnyConnect Compatible VPN (openconnect)
  • F5 BIG_IP Compatible VPN (openconnect)
  • Fortinet Compatible VPN (openconnect)
  • Pulse Connect Secure (openconnect)

Should I use one of this connections, or install something else?
I’ve also tried to install cisco-anyconnect from AUR, but it’s interface does not show anything.

My OS details:

  • Manjaro 22.0.5 Sikaris
  • KDE Plasma 5.26.5
  • KDE Frameworks 5.103.0
  • Qt Version 5.15.8
  • Kernel Version 5.15.102-1-MANJARO (64-bit)
  • Graphics Platform X11

This is the Arch Wiki page on what I think you are talking about:

OpenConnect - ArchWiki

Perhaps the information there will help you.

Thanks for the link, but they recommend to install package networkmanager-openconnect that I already have

Can’t help - I don’t use that VPN service.
The NetworkManager GUI should allow you to create and configure the same things that you use on the command line to successfully connect.
If it doesn’t I can’t help. :man_shrugging:

Finally connected!
Installed openconnect-gui.

Then I switched to configuring network connections.
Click “Add Connection”.
Type: “Cisco Any Connect compatible VPN”.

Entering MyVPNAddress.

(ReportedOS after saving was automatically filled with “Apple iOS”)

Click Connect.
Click the connect button near “VPN Host”
I got a certificate error, click OK
After that, appeared a list with the VPN server groups. I choose the desired one, entered the password (the login has already been entered). Check the boxes “Automatically start connecting next time,” “Store passwords” and “View Log” and click Login.

Then the connection is successful.

It remains to figure out how to save the password not to enter it every time.

I’ve tried to add password in file /etc/NetworkManager/system-connections/MyVPNConnection.nmconnection like:
But it disappears after trying to connect