Cant connect my logitech m590 mouse wirelessly

hey guys, I’m new Manjaro user, sorry if my questions is silly

okay so, I’m having trouble connecting my Bluetooth mouse Logitech m590 to my computer, i have my laptop Lenovo Thinkpad t14s on dual boot, I have connected my mouse on windows perfectly but on Manjaro i can’t do it, first of all i searched forum and saw some solutions but what i can’t seem to find out is my mouse’s Bluetooth ID, there are all sorts of devices with weird ID’s so i cant figure out which is mine

Any help would be much appreciated, thanks for your time.


There is a troubleshoot article for that model on Bluetooth mouse - ArchWiki that might give you the right direction to sort things out.

Since is on the supported list of libratbag/data/devices at master · libratbag/libratbag · GitHub
You could make use of piper GitHub - libratbag/piper: GTK application to configure gaming devices

1 Like

thank you for your response <3

also i tried this link Bluetooth mouse - ArchWiki and the problem i encountered is that I do not know the ID of my mouse device, so i cant do remove, trust, pair commands

When you run
scan on
How many devices are in the list?

1 Like

I’m at the office right now so there are a bunch of other peoples devices, [new] is about 12 devices or so…

Thanks man for taking your time to help me

But you said

So, you can see the ID of it from there …

on windows, it has a name logitech m590 or smth, but I’ll try to find out the ID thanks for pointing me at the right direction

@bogdancovaciu Solved! thanks man

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.