Can't connect Logitech V470 Bluetooth Laser Mouse

Trying connect the mouse to my HP DM4-3000 notebook, currently running kernel 6.0 but the same problem occurs with kernel 5.15, in XFCE and in KDE. I have tried using Blueman and also using bluetoothctl (with Blueman installed and with Blueman uninstalled).

But … this mouse has been working perfectly with this notebook for at least 8 years running Xubuntu and Kubuntu from release 14.04 LTS through 20.04 LTS with never any difficulty connecting, remaining connected, and automatically connecting as soon as the mouse is switched on. Also, I just tried it with Debian 11 Live USB and was able to connect the mouse with minimal effort.

Running Manjaro, even when bluetoothctl or Blueman reports that the mouse is connected, it generally disconnects almost immediately, and it never manages to move the cursor at all.
Xubuntu 20.04 is currently running kernel 5.40, and I believe Debian 11 is running a 5.10 kernel (sorry, I forgot to check when I booted that iso).
Since the mouse works in Xubuntu and Debian it seems that either they both have some kernel patch that’s not in Manjaro, or some firmware that’s not in Manjaro, or ??? but I have no idea how to research this any further.

There are some threads with similar issues but none exactly the same, and none of the suggested solutions were useful in this case.

Here is some typical output that I’ve been getting from bluetoothctl:

This is what I see in journalctl -f while performing the initial connection attempt:

and this is what journalctl shows after the mouse has already been paired and I switch it on and attempt to connect using Blueman:

Here’s some basic system info:

$ inxi -bzE
  Kernel: 6.0.11-1-MANJARO arch: x86_64 bits: 64 Desktop: Xfce v: 4.16.1
    Distro: Manjaro Linux
  Type: Laptop System: Hewlett-Packard product: HP Pavilion dm4 Notebook PC
    v: 0692100000204710000620100 serial: <superuser required>
  Mobo: Hewlett-Packard model: 1793 v: 41.1B serial: <superuser required>
    BIOS: Hewlett-Packard v: F.07 date: 12/21/2011
  ID-1: BAT0 charge: 45.0 Wh (100.0%) condition: 45.0/45.0 Wh (100.0%)
  Info: dual core Intel Core i7-2640M [MT MCP] speed (MHz): avg: 851
    min/max: 800/3500
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    driver: i915 v: kernel
  Device-2: Suyin HP TrueVision HD Integrated Webcam type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    dri: crocus gpu: i915 resolution: 1366x768~60Hz
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter type: USB
    driver: btusb
  Report: bt-adapter ID: hci0 state: up address: <filter>
  Local Storage: total: 698.64 GiB used: 62.07 GiB (8.9%)
  Processes: 195 Uptime: 24m Memory: 5.74 GiB used: 1.95 GiB (33.9%)
  Shell: Bash inxi: 3.3.24

By the way, I think the last journalctl image above has a significant clue in the dbus error: DBusFailedError: br-connection-create-socket. That happens when I right-click on the mouse in the Blueman window and then click “connect”. Then, in the Blueman window a similar error message appears: “Connection Failed: br-connection-create-socket”

But what to do about it?

One more thing: here is a shot of the Blueman info dialog from Manjaro (when the mouse is NOT working). It is EXACTLY the same info that I get from the Blueman info dialog in Xubuntu when the mouse IS working.


I should also mention that my Bose bluetooth headphones connect and work fine in Manjaro (and Xubuntu), so this problem is specific to the mouse.