Cant connect a controller via bluetooth

Bluetoothctl gives this every time.

[CHG] Device (mac address here) Connected: yes
Failed to connect: org.bluez.Error.Failed br-connection-create-socket
[CHG] Device (mac address here) Connected: no

Quite vague information, is that “controller” a gamepad or an audio device? Using pipewire or pulseaudio might want to check about pulseaudio-bluetooth provider …

I have exactly the same error with my knockoff dualshock 4 controller. I’ve tried every possible idea from google and still no solution. Controller actually works first time after pairing but then every connection attempt in both bluetoothctl or blueman fails with quick connect/disconnect and org.bluez.Error.Failed br-connection-create-socket. If I want to use the controller I have to pair it every time.

So far I have eliminated hardware problem (it’s the same behaviour with different bt adapters) and controller itself works flawlessly on another windows pc. I have yet to try newer kernel version (I’m using 6.1).