Can't close Ardour and Muse sequencer from X close button

I use Manjaro Ruah 21.3.0 XFCE, with glibc 2.35-6 official repositories, jack2 1.9.21-1 official repositories, Ardor 6.9-5 official repositories. Ardour don’t close. When click x close button, app freeze.
I don’t know exactly when, but after an upgrade this problem appeared. A month, a month or so ago, it worked perfectly.
I understand it’s not a matter of Ardor. I tried another daw, MusE, and the same problem.
It’s a glibc bug.

A similar issue was reported to Ardour forum — Ardour hanging at shutdown - Linux - Ardour
Ardour developers found an issue with glibc that has been patched for next version v2.36 (not yet released)
Downgrading glibc to v2.35-4 is also reported to work

Thanks for the reply!
Yes, I found the solutions!
One, downgrade glibc …
Second, I chose to switch from pulseaudio to pipewire. It works very well!

PulseAudio and PipeWire are not good for low latency pro audio so switching between sound servers is not relevant or necessary to resolve issue with Ardour