Can't check CPU temperature

I am on the linux kernel 5.11.14
CPU : AMD Ryzen 7 4700U
Manjaro Gnome fully updated
lm-sensors doesnt show tctl or k10temp

i have tried running sensors-detect but no success

Adapter: Virtual device
temp1:        +57.0°C

Adapter: PCI adapter
Composite:    +36.9°C  (low  = -273.1°C, high = +81.8°C)
                       (crit = +84.8°C)
Sensor 1:     +36.9°C  (low  = -273.1°C, high = +65261.8°C)

Adapter: PCI adapter
vddgfx:      724.00 mV
vddnb:       806.00 mV
edge:         +47.0°C
power1:        5.00 W

Adapter: ACPI interface
in0:          11.85 V

Adapter: ACPI interface
temp1:        +47.0°C  (crit = +125.0°C)

i run “sensors” and see cpu temps,but only 5 cores out of 12.

@ayush - output of:

sensors -u
inxi -v 8 -z

@linub - CPU temps are only for the physical cores (or do you have a 12 core processor?)



CPU(s):                          12
On-line CPU(s) list:             0-11
Thread(s) per core:              2
Core(s) per socket:              6
Socket(s):                       1

1 Socket = 1 CPU
6 cores = 6 ALUs with each 2 pipelines bringing the total to 12, but you should see 6 T° numbered from 0-5. (1 per core)


E.G. on my system:

$ lscpu
Architecture:                    x86_64
CPU op-mode(s):                  32-bit, 64-bit
Byte Order:                      Little Endian
Address sizes:                   39 bits physical, 48 bits virtual
CPU(s):                          8
On-line CPU(s) list:             0-7
Thread(s) per core:              2
Core(s) per socket:              4
Socket(s):                       1
NUMA node(s):                    1
Vendor ID:                       GenuineIntel
CPU family:                      6
Model:                           158
Model name:                      Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
Stepping:                        9
CPU MHz:                         3450.472
CPU max MHz:                     3800.0000
CPU min MHz:                     800.0000
BogoMIPS:                        5599.85
Virtualization:                  VT-x
L1d cache:                       128 KiB
L1i cache:                       128 KiB
L2 cache:                        1 MiB
L3 cache:                        6 MiB
NUMA node0 CPU(s):               0-7

and then the T°:

$ sensors
Adapter: ISA adapter
Package id 0:  +65.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +61.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +65.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +65.0°C  (high = +100.0°C, crit = +100.0°C)

Hi, hddtemp is EOL and drivetemp is now a kernel feature (from Linux 5.6 on)

echo "drivetemp" | sudo tee -a /etc/modules-load.d/modules.conf
sudo pacman -R hddtemp

[Note] removing hddtemp might break some conkys, but as said by @merlock below, this package is not even maintained…


sudo systemctl status systemd-modules-load.service


sudo modprobe drivetemp





I think it’s orphaned/unmaintained rather than EOL.

Personally, I don’t care for it:

Adapter: SCSI adapter
temp1:        +36.0°C  (low  =  +0.0°C, high = +70.0°C)
                       (crit low =  +0.0°C, crit = +70.0°C)
                       (lowest = +30.0°C, highest = +40.0°C)

Adapter: SCSI adapter
temp1:        +41.0°C  (low  =  +0.0°C, high = +60.0°C)
                       (crit low = -40.0°C, crit = +70.0°C)
                       (lowest = +39.0°C, highest = +47.0°C)

Adapter: SCSI adapter
temp1:        +35.0°C  (low  =  +0.0°C, high = +70.0°C)
                       (crit low =  +0.0°C, crit = +70.0°C)
                       (lowest = +30.0°C, highest = +40.0°C)


sudo hddtemp /dev/sd[a-c]
/dev/sda: Samsung SSD 860 EVO 500G B              @: 35°C
/dev/sdb: Samsung SSD 860 EVO 500G B              @: 36°C
/dev/sdc: Hitachi HDS723020BLA642: 41°C

Oh, and recommending to remove hddtemp might break a lot of peoples’ conky setups.


Nam1962 never said to remove hddtemp: those commands just activate drivetemp.

@nam1962 :Thanks! Didn’t know about that and I’ve got both hddtemp and drivetemp active now and will drop the former once Conky supports the latter!


Strange that k10temp is missing.

Please try

sudo rmmod k10temp
sudo modprobe k10temp force=1

Does it show up in sensors afterwards?

Are you sure? :wink:


Edit: @Yochanan ninja’d me.

No problem, I added a note.
Anyhow, no pity for such outdated package :wink:

Oops! Missed that!

So is your problem solved now with all the benter in-between? If not, try 5.10 LTS or if that doesn’t work, 5.12 stable as these things are built into the kernel!


Hi !
Small reminder : drivetemp is in the kernel from 5.6 on ! :wink:

1 Like

Edited! Thanks!

:man_facepalming: :grin:

Thank you so much , sorry I didn’t check earlier
This works , I wasn’t sure why k10temp was not probed earlier.


Ok, cool.

If you want to make it persistent across reboots, create a file /etc/modprobe.d/k10temp.conf

sudo nano /etc/modprobe.d/k10temp.conf

and paste the following text

options k10temp force=1

(save with CTRL+S, exit nano with CTRL+X)

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.