Can't change the shell in KDE

I want to change my default shell (from zsh to bash). I used chsh command like this but nothing changed even after restart. Could you please tell my whats the problem and how can I fix it?

Password: 
New shell [/bin/zsh]: /bin/bash
Shell changed.

You used this command?
chsh -s /bin/bash
or you went on doing it with sudo ?

Are you on Gnome as per user description of your profile, or you are on KDE Plasma? For KDE see this:

2 Likes

It worked. I just switched to plasma recently(Ill change my profile sorry for that). Thank You.
For people comming to this:

  1. Go to the Konsole app
  2. Click on “Settings” in the menubar.
  3. Click on “Manage Profiles…”.
  4. Click on your default profile
  5. Hit edit.
  6. In “General Section” change the "Command: " entry and replace /bin/zsh with /bin/bash
  7. Hit “Ok”
2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.