Cant change screen refresh rate on a gaming laptop

I currently have a laptop with a 300hz intel cpu and 3060.
but in settings and xrandr it shows it can only do 60.
i made a new seperate manjaro install and it did detect that the

monitor was capable of 300 but when changing the setting to it it was most definitely still only 60hz

the laptop im using is the tuf f15 (2022)

i moved the m.2 ssd from an old laptop into this new one. i changed some bootloader settings to make it boot with this new laptop


  Kernel: 5.17.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
    root=UUID=f85196b6-8b8b-42d1-b79b-566db2978bf5 rw quiet apparmor=1
    security=apparmor udev.log_priority=3 quiet acpi_backlight=vendor
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX507ZM_FX507ZM
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FX507ZM v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: FX507ZM.310 date: 01/26/2022
  ID-1: BAT1 charge: 79.9 Wh (86.5%) condition: 92.4/90.2 Wh (102.4%)
    volts: 16.0 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: discharging
  Device-1: hidpp_battery_0
    model: Logitech G305 Lightspeed Wireless Gaming Mouse serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: discharging
  RAM: total: 15.29 GiB used: 3.65 GiB (23.8%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
    arch: Alder Lake family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x415
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1113 high: 1772 min/max: 400/4679:4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 785 2: 759 3: 1333
    4: 1179 5: 1772 6: 1035 7: 1301 8: 984 9: 1299 10: 1201 11: 1018 12: 1473
    13: 992 14: 1225 15: 972 16: 1133 17: 869 18: 976 19: 1004 20: 957
    bogomips: 107560
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2 bts
    cat_l2 cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault
    cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c
    flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep serialize sha_ni smap
    smep smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq
    umip vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: ASUSTeK
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 510.73.05 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-05) arch: Ampere bus-ID: 0000:01:00.0
    chip-ID: 10de:2520 class-ID: 0300
  Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-7:3 chip-ID: 322e:202c class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: TL156VDXP0101 built: 2021 res: 1920x1080 hz: 60
    dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.0.4
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-3: ASUSTek C-Media Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-9:4 chip-ID: 0b05:6203
    class-ID: 0300
  Sound Server-1: ALSA v: k5.17.9-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Ethernet I219-LM vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 0000:00:1f.6 chip-ID: 8086:1a1e class-ID: 0200
  IF: eno2 state: down mac: <filter>
  IF-ID-1: outline-tun0 state: down mac: N/A
  IP v4: <filter> scope: global
  IF-ID-2: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
  IP v4: <filter> scope: global
  IP v6: <filter> scope: global
  IP v6: <filter> virtual: stable-privacy scope: link
  IF-ID-3: virbr0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:5 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 1.84 TiB used: 360.54 GiB (19.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Samsung
    model: MZVLQ1T0HBLB-00B00 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: FXM7301Q temp: 40.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Crucial model: CT1000P5SSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: P4CR324 temp: 61.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 631.32 GiB size: 620.34 GiB (98.26%)
    used: 360.47 GiB (58.1%) fs: ext4 dev: /dev/nvme1n1p4 maj-min: 259:4
    label: N/A uuid: f85196b6-8b8b-42d1-b79b-566db2978bf5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 76.5 MiB (79.7%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
    label: N/A uuid: 0C51-90DC
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:6 size: 260 MiB fs: vfat label: SYSTEM
    uuid: F88E-D04D
  ID-2: /dev/nvme0n1p2 maj-min: 259:7 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:8 size: 930.77 GiB fs: ntfs label: OS
    uuid: 4E029065029053B5
  ID-4: /dev/nvme0n1p4 maj-min: 259:9 size: 650 MiB fs: ntfs label: RECOVERY
    uuid: 849EC7199EC70322
  ID-5: /dev/nvme0n1p5 maj-min: 259:10 size: 22 GiB fs: ntfs label: RESTORE
    uuid: 4E465F65465F4D39
  ID-6: /dev/nvme0n1p6 maj-min: 259:11 size: 200 MiB fs: vfat label: MYASUS
    uuid: 9A5F-7F5F
  ID-7: /dev/nvme1n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-8: /dev/nvme1n1p3 maj-min: 259:3 size: 300.08 GiB fs: ext4 label: N/A
    uuid: 471436ec-2ca3-4169-b45a-8420c017d743
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-2:2 info: Logitech USB Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c53f class-ID: 0300
  Device-2: 3-7:3 info: Sonix USB2.0 HD UVC WebCam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 322e:202c class-ID: 0e02
  Device-3: 3-9:4 info: ASUSTek C-Media Audio type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 0b05:6203 class-ID: 0300
  Device-4: 3-10:5 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 405 Uptime: 13m wakeups: 1746 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 1691 apt: 0
  pacman: 1678 lib: 435 flatpak: 0 snap: 13 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.16

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
1 Like

it’s not trivial, the i915-driver isn’t capable to use the edid-config of the screen properly. a short check with

glxinfo | grep server

will show up that the igpu (intel) is used
please post the output

1 Like
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:


prime-run glxinfo | grep server

should show up nvidia
does it, please post the output

1 Like
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

so i just need to launch things useing prime-run?

if it was that simple. if you want i’ll show you how to use the nvidia as primary and constant gpu and you can check to use higher refresh rates with nvidia.

yes please

is there any way to set it to dynaimically change for battery saving on windows?

the battery-consumption is more a question what load you use. i can’t see any advantage in using the intel-i-gpu. there was an option at optimus to switch but actually optimus has some flaws. maybe it’s solved with the next version but actually i don’t think so.

sounds good then. how do i go about switching the nvidia?

well maybe there is a way to use switching.
first make sure that you’re using X11 or wayland. it should be X11
the output of


shows what session. it should be X11

im very certain its X11

i had to go to work so i dont have the laptop rn but if you post instructionsill try them later

install optimus-manager and use the following instructions:


looks good ill try that later thanks

i installed optimus manager rebooted and now it wont boot. there is nothing noticable in the logs. it turns on and i can see the boot logs but it doesnt go to tty or any desktop

may you explain what steps you did. did you proof to be on X11 before installing ?

yes it is x11

glxinfo | grep server

what’s the output ?

server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:

i removed optimus otherwise it wouldnt get past the loading

whenever i tried to boot it would give me this error

Jun 10 19:34:04 poslop-m sddm[1096]: Failed to read display number from pipe
Jun 10 19:34:04 poslop-m sddm[1096]: Display server stopping...
Jun 10 19:34:04 poslop-m sddm[1096]: Attempt 1 starting the Display server on vt 1 failed

strang, may you explain step by step what you did ?
in general, configuring plasma to X11, installing and enabling optimus-manager, setting up nvidia as kernel parameter and updating grub will force to run with nvidia as primary driver.