Can't Change Refresh Rate

I’m somewhat still a noob, so apologies in advance. I just built an MSI Mag B550 Tomahawx Max MOBO, with an MSI GeForce RTX 3060 GPU. I’m currently running Manjaro KDE 23.1 Vulcan. I have the monitor set to 3840X2160 but the highest refresh rate is 30Ghz. My monitor will do 144.

When running xrandr, it simply comes up with “_xrandr:6: no matches found: (-r --rate --refresh)*-r:target refresh rate:”

As stated, as a noob, any help would be greatly appreciated. Love Manjaro overall!

Does the refresh rate go up if you turn the resolution down? If so, then I’d suspect the cable that your using isn’t capable of high data rates, and so you get limited.

Also I don’t think that a 3060 can do 4k@144Hz over DisplayPort, as it’s only DisplayPort 1.4. You’ll need to use HDMI for that.

When I go to 1920X1080, it does allow a refresh of 60 at least. So maybe it is the HDMI cable? I’ll look into a better cable. But why doesn’t Xrandr show any matches? Will changing the cable allow me to reach 144, or will there be other settings I’ll need to do? Thanks in advance for the help

I’m not sure about xrandr’s behaviour - it’s not a tool that I personally use. However, running it on my own machine it doesn’t appear to actually be able to control the refresh rate. Possibly because I use wayland, so I may not be able to test things myself.

Also do note I’m not 100% sure about the HDMI cable being the culprit, just that I think it’s the most likely culprit.

I just checked, and the HDMI cable I’m using is rated for 8k, so I doubt the cable is the problem.

dgdg, so, if the cable isn’t the problem, how would I change the refresh rate outside of xrandr? I mentioned xrandr because in my search it seemed to be a solution for some, but may not be for my setup.

Firstly, How much do you trust the manufacturer? I recall LTT doing a video on cables with a cable tester and the results were pretty… bad, let’s say. If you still have it, I’d recommend using the cable that came with the monitor, as that’s the most likely to be ‘known good’.

For the second post, I just use the display settings in Gnome. I think KDE should have an equivalent setting in System Settings - Display.

My suspicion is it has more to do with the generic Linux driver for the GPU than anything. I’ve thought about trying the Nvidia driver but have heard of nightmares for doing so.

You should really check you cable connection the gpu and monitor.

With high refresh rates the quality of the cable matters.

You’re using the Nouveau open-source driver?

Nouveau is a fantastic project of reverse engineering, and it’s amazing that it works as well as it does, but I would strongly recommend installing the proprietary driver. It’s very nearly necessary to get Nvidia hardware working properly. I think Manjaro has pretty good integration of the proprietary driver via Hardware Configuration in Manjaro Settings Manager (I’m on an AMD card, so I can’t test this myself). Or for more granular control on the command line, you can consult this Wiki page.

I doubt that, but it’s not hard to install the non-free driver using mhwd and that’s what most NVIDIA owners use.

4K @ 30Hz is typical of a HDMI 1.4 cable. There are many junk cables out there so you really do need to verify that it is actually capable of what it says.

Also post output of inxi -Ga.

Two things. I will try another cable in case. Also, I tried installing the Nvidia driver via the method shared and after reboot, all that showed was the mouse and a blank screen. Had to reinstall the OS. Here’s a copy of the INXI:

Device-1: NVIDIA GA104 [GeForce RTX 3060] vendor: Micro-Star MSI
driver: nouveau v: kernel non-free: 545.xx+ status: current (as of 2023-11;
EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
built: 2020-2023 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 2b:00.0 chip-ID: 10de:2487
class-ID: 0300
Device-2: Logitech BRIO 4K Stream Edition
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 3.1
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 4-4:2 chip-ID: 046d:086b
class-ID: 0300 serial: D59CE460
Display: wayland server: v: with: Xwayland v: 23.2.3
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,vesa dri: nouveau gpu: nouveau display-ID: 0
Monitor-1: HDMI-A-1 res: 3840x2160 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia nouveau platforms: device: 0 drv: nouveau
device: 1 drv: swrast gbm: drv: nouveau surfaceless: drv: nouveau wayland:
drv: nouveau x11: drv: nouveau
API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 23.3.3-manjaro1.1
glx-v: 1.4 direct-render: yes renderer: NV174 device-ID: 10de:2487
memory: 11.69 GiB unified: no display-ID: :1.0
API: Vulkan Message: No Vulkan data available.

Doesn’t seem to be detecting your monitor properly. What does ddcutil detect show?

Device /dev/i2c-17 is not readable and writable. Error = EACCES(13): Permission denied
Device /dev/i2c-18 is not readable and writable. Error = EACCES(13): Permission denied
Device /dev/i2c-19 is not readable and writable. Error = EACCES(13): Permission denied
Devices possibly used for DDC/CI communication cannot be opened: /dev/i2c-17 /dev/i2c-18 /dev/i2c-19
See I2C Device Permissions - ddcutil Documentation
Invalid display
I2C bus: /dev/i2c-7
DRM connector: card0-HDMI-A-1
EDID synopsis:
Mfg id: SAM - Samsung Electric Company
Product code: 29201 (0x7211)
Serial number:
Binary serial number: 16780800 (0x01000e00)
Manufacture year: 2022, Week: 1
DDC communication failed. (getvcp of feature x10 returned Error_Info[ENXIO in ddc_write_read_with_retry, causes: ENXIO])

BTW, the monitor is a Samsung 43", QN43Q60BAF

  1. Please read the manual for that TV and make sure you have it setup correctly. In particular;

The native resolutions are 3840 x 2160 @ 60 Hz (UHD models) and 7680 x 4320 @ 60 Hz (QN7**B series or higher) with the Input Signal Plus set to On. The native resolution is 3840 x 2160 @ 30 Hz with the Input Signal Plus set to Off.

  1. 144Hz on that TV requires Freesync which is AMD tech. Nvidia only supports it on monitors that they have certified. It may or may not work.

What values do you get in “Refresh rate” list ?

Thanks MrLavender. It appears the problem lies with the monitor. Great catch! By switching to Input signal plus, I get 60hz. Thanks. at least I can get 60hz now until I upgrade the monitor. Greatly appreciate the effort for a noob. Have a great weekend!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.