Can't change profile picture

Hello everyone.

The gist of it is: I can’t “upload” any profile picture. I can choose between the default ones, and they do change, but if I want a custom image for my profile, I just can’t. It doesn’t work.
So I went to google, as you would, and found that it may be related to the latest ‘accountsservices’. A user reported that downgrading from 22.04.62-2 to 0.6.55 fixed it for them, so I tried that. Again, didn’t work. Even tried downgrading to 0.6.54 and still nothing.
And yeah, I realize there are (at least) two ways to change my picture: the main ‘Settings’ & ‘Manjaro Settings Manager’. I’ve referred thus far to the ‘Settings’ app. If I try to change through ‘Manjaro Settings Manager’, it kind of works, but also does nothing. As in: it only changes inside the app.

It’s a reported issue on the ‘accountsservice’ gitlab, which unfortunately, I can’t link here.
Is there a fix or I’ll have to wait for the patch?

I’m fairly new to Manjaro, eager to learn, but I’m at a loss here. Can anyone help?
Oh, running the latest versions of everything (except ‘accountsservvices’, as stated before).
As in: installed yesterday & ran --Syu multiple times.

1 Like

It’s a accountservices package bug. It’s fixed with version 22.04.64 or newer so wait for an update, it works if you change it in Manjaro Settings Manager.

Related stuff

Similar bug report - Unable to set profile picture via gnome control center, because /tmp is marked private in accountsservice service file (#98) · Issues · accountsservice / accountsservice · GitLab

Also see - Can’t change the User Picture - #3 by ydar

sudo chmod 775 /var/lib/AccountsService/users

Ran it, did nothing though. Alt+F2 + ‘r’ didn’t help. Anything else I should do?

Guess I’ll have to wait. Already changed it in Manjaro Settings Manager, did nothing
Yeah, seen those two, thanks for the reply

Until the developer’s fix it, this is reported to work:

The issue is with the service file for AccountsService:

sudo nano /usr/lib/systemd/system/accounts-daemon.service

this is set to
setting it to:
and reboot will solve it


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.