Can't build qt4

pamac says I’d need to update qt4 via the AUR, but it fails to build. Can someone help? I am not that advanced with the AUR

What is the software you need that is still using qt4 ?

i dont know, it just says i need it
I will check the dependencies really quick

I had a similar situation after a recent update. Turns out I didn’t need qt4. I installed qt6 and removed qt4.

1 Like

Yes i don’t have any dependencies on qt4, will remove it


I have the same problem for a few days.

Read about building and installing via chroot should be a solution for that problem, but i did not get along with any instructions on how to do this. I need qt4 for keepassx2.

Is there any step-by-step instruction?

Did you consider KeePassXC? Is based on QT5 and available in the official repo.

I tried all other KeePass alternatives, but none fits my expected user experience. KeePassXC is horrible for its extremely large entry icons.

So i will either update qt4 by chroot build if someone can help me how to archive this, otherwise I’m going to add qt4 to PkgIgnore, as i guess KeePassX2 is not going to need the latest qt4 version at all: So it will no longer appear as “new update available” (by push message or task bar update info icon).

same qt4 problem for me. when i try to remove it says epson-printer-utility is dependent on it. I dont want to mess up the printer settings.
Both octopi and pacman keep showing this update.
what can i do ?

The second option i was talking about in my previous post works the following way:

  • Open the file /etc/pacman.conf with root privileges (sudo) with your favourite editor, e.g. sudo vim /etc/pacman.conf
  • Look for the line beginning with IgnorePkg or #IgnorePkg
  • Remove the prefixed # at the beginning if given
  • Add the two packages at the end, if there are already packages in the list, separated by a white space: IgnorePkg = qt4 lib32-qt4
  • Save and close the file
1 Like

Thanks magynhard, worked a treat.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.